Scrolling lag on DeathAdder Elite when CPU load goes up

Discussion in 'Mice and Surfaces' started by fidorulz, Feb 12, 2019.

Thread Status:
Not open for further replies.
  1. fidorulz

    fidorulz New Member

    So loving the mouse but once in a while there is lag when moving my cursor.

    I checked and tweaked all the DPI settings and issue remains

    Seems to occur when in doing stuff like downloading large files or opening apps.

    The lag is very slight and only for split sec

    its barley noticeable but annoying none the less

    I uninstalled and reinstalled the mouse as well as reinstalled synapse and same thing

    Im running windows 10
     
  2. ARMOR_152

    ARMOR_152 Well-Known Member

    If you have a high polling rate like a 1000, and a low powered CPU that might be the problem.
     
  3. fidorulz

    fidorulz New Member

    I have it set to 1100 and use the computer for work so no gaming.

    Im using a Lenovo ThinkPad T460 with

    i5-6300U 2.40ghz
    8GB RAM
     
  4. 0V3R_K1LL

    0V3R_K1LL Well-Known Member

    Try exiting Synapse and then when you get CPU load see if your mouse lags. Might be something in the software taxing your system.
     
    DRIFT_IT likes this.
  5. fidorulz

    fidorulz New Member

    Seems to occur less but I need this to program all the keys

    I uninstalled and reinstalled the app and same thing

    i tried other apps to map the mouse keys but some are not registering
     
  6. 0V3R_K1LL

    0V3R_K1LL Well-Known Member

    Try checking task manager and see what program is taxing your CPU. If its something like an antivirus you might be better off disabling it.
     
    DRIFT_IT likes this.
  7. necroscumbag

    necroscumbag New Member

    Okay, I thought I been going nutz... I am running into mouse lag as well as DPI not staying consistent.... I have check everything from system resources to internet. only time iget consistent performance with out razer software. which is unacceptable... even using tournament driver setup... also I been noticing sticky left mouse key issues... mouse is less then 2 weeks old.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >