streamer companion app broken?

Discussion in 'Razer Support' started by Psycho2aTee, May 17, 2021.

Thread Status:
Not open for further replies.
  1. Psycho2aTee

    Psycho2aTee New Member

    i have the razer kitty kraken headset and no matter what i do i cannot get it to work with tthe streamer companion app. it worked fine out of the box but then at some point the streamer companion app needed to update and since then the lights on the headset are either stuck on white or off completely and no longer react to any stream actions even though they pop up in the feed in the app. i have just bought the seiren emote mic and im really concerned that that wont work either since there seems to be something wrong with the app. please help me as this was a big part of my stream and now its completely broken!
     
    AmaiYasai likes this.
  2. AmaiYasai

    AmaiYasai New Member

    My razer kitty kraken headset never worked at all with the stream alerts other than the streamlabs donation/tip alert. The Twitch ones (the most important ones too) never work when I'm live. The app shows someone follows, raids etc, but the headsets don't light up. But for some reason when I use the test button on the app, it works.
    Just wish there was actual support for this because I didn't just buy a $100+ headset for nothing! I got these for my viewers and myself to enjoy. For now I'm just using the Chroma Visualizer so there's at LEAST some kind of magical lights dancing on my headset when I stream.
     
    AnipR15 likes this.
  3. AnipR15

    AnipR15 Active Member

    You are talking about the app problem or your hardware light? Just make it short.
     
  4. AnipR15

    AnipR15 Active Member

    Here I got some solution to try out.

    First you open your "Razer Synapse App" and then at above Go to select "Connect" Tab, After that you see whether Streamer Companion App was on the top of the list or Chroma Visualizer, Make sure Streamer Companion App was at the Top(Drag it by holding Left Mouse Click to the Top) and lastly Make sure to Toggle On Enable This App located at the upper right corner. Try it out, drop by here to share whether it did help solve your problem or not yet. So we can figure out the another solution.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >