Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse 2.0 can't locate my headphones

Discussion in 'Razer Support' started by CORALPurpleNavyfirst418, Oct 11, 2020.

  1. I have been using Synapse 2.0 with my Kraken Pro for two years but there was a problem with sound and I decided to reinstall it. Now it can't locate my headphones and I don't have razer surround. I tried several times to reinstall it and even deleted all razer files in the disk C.
     
  2. joshua88wa

    joshua88wa New Member

    Edit: I got Synapse 2.0 working after reinstalling some of my Microsoft Visual C++ Redistributables as mentioned here. And then following the clean installation instructions word for word here. (including installing Synapse 3 which I'm pretty sure I don't need)

    ---
    I am having a similar problem with Synapse 2.0 except with recognizing my Orbweaver. It was not working, so I reinstalled, and now its like it doesn't see it anymore. I've tried uninstalling and clearing ProgramData then reinstalling. I tried disabling my anti-virus. I've tried uninstalling the drivers and rebooting the computer. I am at a complete loss on what to do.

    One weird thing, even though the main window doesn't show any devices
    Razer Synapse No Device.PNG
    The Taskbar does show it
    Razer Synapse Orbweaver.PNG
    But clicking on Razer Orbweaver does nothing.
    I doubt that it is simply defective hardware. I'm almost certain this is a software issue as the keypad works as if it is in default mode, I just can not load any of my settings or create new ones.
     
    Last edited: Oct 11, 2020
    smartOchreguide808 likes this.
  3. Don't work for me, still have a menu about registration razer devices
    upload_2020-10-12_10-11-20.png
    I don't know really what to do, I have reinstalled it 3 times and I am almost gave up, maybe there is technical support that could do something
     
  4. P.S I even have a badge on my account that says that I have a Razer headset :slightly_sad: upload_2020-10-12_10-18-9.png
     
  5. Synapse 2 still don't recognize my headphones but my dynamics show that there is available Razer Surround Audio controller, but when I use there aren't any sounds. It starting to be ridiculous.
    upload_2020-10-13_11-7-54.png
     
  6. Technical Support ignores me, i thought razer is more client-oriented and would give me at least minimal help with technical issues.
     
  7. Just trying to get a little attention from you guys, any thoughts on how I could solve this? 3 weeks passed and nothing changed.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >