Synapse 3 and Cortex Installers Won't Run

Discussion in 'Razer Support' started by Elraim, Oct 18, 2020.

Thread Status:
Not open for further replies.
  1. Elraim

    Elraim New Member

    I just built a new desktop and got the Kraken Ultimate, Ornata, and Naga Trinity. I downloaded Synapse 3 and Cortex and they worked for about a month until they just...didn't.

    I uninstalled them and then immediately tried to reinstall, but now the installer won't even open. When I try, an error window opens and closes before I can even see it, and a .err file gets created in the folder with the installer.

    I've tried
    1) Deleting all trace of Razer software and logs from my system
    2) Making sure I have the most recent .NET framework and other updates
    3) Deleting any Razer in registry
    4) Unplugging the peripherals, uninstalling the devices in device manager, restarting the PC and reinstalling the drivers

    None of this has worked and I get the same result everytime. This only happens with Synapse 3 and Cortex, I was able to successfully install Synapse 2. Help!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >