Synapse 3 won't recognize Naga Trinity Mouse

Discussion in 'Razer Support' started by Courtney125, Feb 25, 2021.

Thread Status:
Not open for further replies.
  1. Courtney125

    Courtney125 New Member

    I got this new mouse yesterday, and Synapse worked fine then, I was able to set up my mouse and program all of my buttons. Today, all of the buttons still have the same programming, but I wanted to change something so I went to change it in Synapse and found out Synapse won't see my mouse. I tried updating and reinstalling synapse, but that didn't work and I'm not sure what to do next.

    I tried to find answers here, but couldn't find a helpful thread. I don't really have hours to spend on this going through every single thread though, so I could very well have missed something.
     
  2. pestilencephase

    pestilencephase New Member

    I have the same problem. I've been all over Reddit and Synapse 3 will not recognize my Naga Trinity. It hasn't ever recognized it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >