THX spatial Audio skyrockets Windows audio device graph isolator

Discussion in 'Razer Support' started by Tuonra, Jul 12, 2019.

Thread Status:
Not open for further replies.
  1. Tuonra

    Tuonra New Member

    Hi there,

    I've noticed a crackling in my Razor Nari Ultimate for some time now, and narrowed it down to moments of intense CPU load. but now I've found the high CPU load is caused by a sudden spike in Window's Audio Device Graph Isolator Process. And this happens only when I run 2+ apps that utilize my THX Spatial audio for surroundsound. For example A livestream in Chrome and a fullscreen game on Steam, in this case 'Underlords'. Running only one of these gives no issue since WADGI does not have to step in to modulate the audio channels ( disabling WADGI alos just mutes the most recently launched app that is playing audio, so that isn't a fix).
    Now I ran a -for me- conclusive test where I enable and disable THX Spatial Audio with Task manager and Chrome and underlords open, WADGI spikes from <5%CPU to >15%CPU. (Screenshots)

    THX on: https://imgur.com/gallery/Baku9bj
    THX off: https://imgur.com/gallery/1MY5ZeT

    Guess I'll be stuck in no-THX sterao mode since the Crackling is frankly unbearable, but I hope this conflict gets fixed soon. If anything happens, do let me know.

    Thanks in advance,
    -Tuonra
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello! Have you tried reinstalling Synapse? If you haven't yet, please do and let me know how it goes.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >