Unable to Access Razer Synapse

Discussion in 'Razer Support' started by SIKA_, Mar 19, 2021.

  1. SIKA_

    SIKA_ New Member

    Hello,
    Today I have encountered quite an unusual problem with Razer Synapse. My computer is now unable to run the software without it crashing. I first noticed this when my Razer keyboard would not display the RGB setting that I set it to and it started using its default RGB setting. After attempting to resolve myself, I tried to uninstall Razer Synapse to reinstall it but with no resolve. I am met with a loading screen for a few seconds and it disappears. I have tried going into the file library and deleting the files but was unsuccessful. I updated to the last Windows and have the same problem. I am stuck and hoping this can be an easy fix. Any help is appreciated.
     
  2. SaadZaeem

    SaadZaeem New Member


    Here's a video to help you out!
     
  3. SIKA_

    SIKA_ New Member

    Not helpful but thanks. I am unable to uninstall Razer Synapse to begin with. Once I click uninstall, the razer menu opens for a few seconds and then closes like the program crashed.
     
  4. Girbilcannon

    Girbilcannon New Member

    This same issue just started happening to me tonight when I went to run synapse. It worked about a week ago, but now if I launch the application through the start menu it gives me the login screen (with a default windows application border around it) and then crashes only a few seconds later. I was forced to do a windows update a couple of days ago (KB5001330) and being a feature update that messes with installed hardware, this may be causing some sort of interference with Synapse. I'll look a little more into it, but so far i'm dead in the water with Synapse.
     
  5. Girbilcannon

    Girbilcannon New Member

    just a quick update on the situation. I have not had a chance to try uninstalling the driver because that is my absolute last resort. After uninstalling synapse 3, I tried installing the latest version of Synapse 2, and that still works (you must uninstall 3 for it to work). It's not as polished as version 3, but if all you need is basic lighting control and the ability to set up profiles with macros, version 2 works perfect.

    I would like to see a fix for version 3 come out soon so I can get all my stuff back on the cloud and all my custom lighting back, but this will have to work for now.
     
  6. Girbilcannon

    Girbilcannon New Member

    OKAY FIXED!
    Windows update KB5001330 was the problem for me. After removing the update completely from windows 10, The login and Synapse windows no longer crash. Hope this works for you. If it's not that update, try removing the updates closest the time of which you started encountering the issue. Hopefully Razer will come up with a fix for this soon.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >