Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Viper Mini no laser

Discussion in 'Razer Support' started by upDarkRaspberryever106, May 20, 2020 at 10:38 AM.

  1. Hi All,

    I have a Viper Mini I got last week, was very happy with it.

    Turned everything on this morning, and now I have no laser or cursor movement.

    The system still recognizes the existence of the mouse in Device Manager, and the buttons function, but no pointing function.

    I've tried unplugging and re-plugging the USB, tried a different computer, same result, no laser.

    What to try next?
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    It is possible that the sensor of your Viper Mini has been damaged. That said, do you mind sharing a clip showing what happens when you plug the mouse in and how it appears on the Device Manager?
     
  3. Before plugging in mouse:

    upload_2020-5-22_16-20-53.png

    After plugging in mouse:

    upload_2020-5-22_16-21-46.png

    The LED's on the mouse light up, but not the laser/sensor. I've already done a reset on the mouse itself.
     
    Razer.Caziel likes this.
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    From the looks of it, everything else is working but the sensor. PM me the serial number of the mouse, I'd like to check for possible firmware solutions before we go the RMA route.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >