Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Weird System Lag with Synapse 3 Only

Discussion in 'Razer Support' started by raznet, Oct 15, 2020.

Thread Status:
Not open for further replies.
  1. raznet

    raznet New Member

    I have a very strange lingering problem with Synapse 3 and my Razer Basilisk Ultimate.

    After about 30 minutes of using the mouse, every time I make a movement my entire system will slow down and freeze. Audio will stutter and frames will drop. Even the lighting on my Razer Keyboard lags too!

    As soon as the mouse stops moving, everything returns to normal. The problem is much worse in wireless mode.

    I have tried uninstalling Synapse 3 (which means I can control lighting configurations and profiles) and the problem doesn't occur. Even after a clean install (tried this multiple times) the problem still happens.

    The temporary fix is to unplug and then replug the mouse. This will then 'reset' the lag for another timed amount.

    I have tried reporting this via the feedback and bug reporting, but no one got back to me.

    Does anyone else have this issue? And does anyone have any idea why this happens?

    Nothing unusual can be found in Task Manager and disabling Razer Synapse 3 does not fix this.

    Asus Z170-K
    i7-6700
    16GB RAM - 3200MHz
    GTX 980 ti - 6GM
    1TB SSD
    4TB HDD


    ^ In case anyone wishes to know...
     
    neoDD69 likes this.
  2. neoDD69

    neoDD69 New Member

    Hi raznet,
    me too have a lag problem with Synapse 3, every time I switch application! ... from years, but no one read my notes.
    Good luck.

    One curiosity ... do you use Windows 10 of some Windows Insider preview ?
    Me yes and I suppose that Synaspe 3 is not ready for the preview versions of Windows ... they are a little lazy ;)
     
  3. raznet

    raznet New Member

    Just a standard Windows 10 Home. I recently upgraded my PC, replacing the MB, CPU & doubled my RAM to 32GB, and I don't seem to have the issue at all, even on Wireless mode.

    This is a really strange problem. No idea what the cause could be.
     
  4. Twmkenny

    Twmkenny New Member

    Hello,

    I have exactly the same problem. Since the new update, the mouse has lagged, and also has a slight delay. Since then I have had extreme fps drops on all settings (high to low)

    MSI b450
    Ryzen 7 3700x
    32 Gb Ram
    Nvidia GTX 1660 TI
     
  5. neoDD69

    neoDD69 New Member

    Guys, it's, for me, a years long problem ;(
    I'm a senior software developer, in Windows, and I've some ideas where Razer Guys can put their eyes and hans to try to solve the problem.

    The problem is that NO ONE with sufficent skills to escalade the issue to Razer senior developers will read this post and other messages that I've wroed about ... the big enterprises mostly interact "blinded", or oneway, with the real world and real users.
    Logitech have a SW like Synapse 3 but works a LOT BETTER (I'm was a Logitech customer for decades) but theie hardware goes down, very very down, in quality, reliabilit and design in last years.

    Razer in the other hand producte grate HW but thier are so young in SW ... or miss some specialist in the team that develop Synapse 3
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for posting your concerns here. Please gather your Razer Synapse 3.0 logs, then save it via Google Drive or to any online drive account as the team will need this during the investigation. Ensure that your PC's antivirus or firewall is not blocking any Razer-related files. Delete the files inside path C:\ProgramData\Razer\GameManager\ServiceSettings.xml and restart Razer Synapse. Should the issue persists, please perform the steps below and see if it helps:

    "Clean reinstallation of Razer Synapse with registry delete."

    Note: Please be careful and not delete other files/folders as it may corrupt your Windows operating system. Check the steps below:

    1. Uninstall Synapse and delete all files in C:\Program Files (x86)\Razer and C:\ProgramData\Razer directories. These folders are hidden by default, so please be sure to unhide them.
    2. Uninstall Razer drivers by going to "Device Manager" from Control Panel.
    3. Press Windows + X key and choose Command Prompt on the menu.
    4. Type regedit in the command prompt window and press enter.
    5. Please go to this path and check if you have it:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW643NODE\Razer\
    *Please delete everything that's in the Razer folder. Please reinstall Synapse after deleting all the files inside the Razer folder
    6. Download a fresh installer and reinstall, then restart your PC.
    7. Add Synapse to your firewall exemptions and update your .NET Framework at https://dotnet.microsoft.com/download/dotnet-framework/net48

    Feel free to send me a PM together with the online drive link that contains the Razer Synapse logs. Let's continue from there.
     
  7. neoDD69

    neoDD69 New Member

    @Razer.SpeedCr0ss, I've done all your suggestion (I'm a senior developer and ICT engenieer) and the result is:
    NOTHING CHANGED!

    It tooks always SECONDS (1-2) to change the PROFILE!
    and meanwhile the MOUSE STOP RESPONDING and LAGGING "A BESTIA" !!
    Seems that the MOUSE remain DISCONNECTED (not for Win): the movements when change profile was IGNORED ... like you move the mouse when it's inches away from the table!

    Any suggestions different to escalade the issue to SENIORS DEV?
     
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. And yes, I'll definitely report this to our devs. Please help us by send me the following:

    a. Razer Synapse 3.0 logs
    b. Screenshot of Windows version (Hit Windows + R. Open the Run box with then type winver)
    c. A video showing the issue.

    Save it via Google Drive or to another online drive account then include it in your PM or paste is in your submitted case. Let's continue from there.
     
    neoDD69 likes this.
  9. neoDD69

    neoDD69 New Member

    Thanks, replied via PM.
     
  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi! I've replied to your PM. I'll wait for your follow-up.
     
    neoDD69 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >