[Win10] Razer Synapse (3 OR 2) failing to run.

Discussion in 'Razer Support' started by AstraTheDragon, Jan 12, 2019.

Thread Status:
Not open for further replies.
  1. AstraTheDragon

    AstraTheDragon New Member

    Sorry if this is a well-known issue that has a fix posted elsewhere; I scanned the forum a bit to see if I could find anything but that was fruitless.

    As the title says, I haven't been able to run any kind of Razer Synapse programme. I use a Razer Cynosa Chroma keyboard and a Razer Naga Chroma mouse.

    I last updated Synapse a few days ago and following that Synapse seemed to have disappeared from my start menu and my desktop shortcuts would not work. (I restarted my computer to enable the update when I thought I saw Razer Central prompt me to, it seemed to have finished updating.)I tried to reinstall Synapse 3, which seemed to work but it would not run. (I also installed Razer Cortex at the same time, which worked fine.)

    Following that, I tried to delete all traces of Razer software and reinstall it, but once again a reinstalled Synapse would not run.

    I tried again to remove all traces of Razer software and even deleted the device drivers, reinstalling Synapse but to no avail.

    Throughout all of this, Razer Central has worked fine.

    I think I've done everything I could try to fix it myself; is there something I'm missing? Does anyone have any ideas on how to fix this?
    Thank you.
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi @AstraTheDragon, please reinstall Microsoft .Net Framework after updating Windows. Shoot me a PM if the problem persists so I can help you further isolate the issue.
  3. AstraTheDragon

    AstraTheDragon New Member

    Thanks for responding, I forgot to mention that after I updated Razer Synapse 3 yesterday it now boots fine, but it's no longer recognising my Cynosa Chroma keyboard and Naga Chroma mouse. I've tried removing and replacing them after deleting the drivers again to set them up but to no avail. :confused_:
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Apologies for the delayed response. Should you still need further assistance please send me a PM so we can do some troubleshooting.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >