Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Windows freezes

Discussion in 'Razer Support' started by Breuert, Apr 19, 2019.

Thread Status:
Not open for further replies.
  1. Breuert

    Breuert New Member

    Hey guys,

    I have a problem when installing an update in Synapse 2.0.
    I try to update my Deathstalker Ultimate because the Switchblade is not working, at al.
    I tried "everthing",
    - re-installed Synapse
    - disconned the USB-devices (I have the Deathstalker Ultimate, Ouroboros and the Tiamat 7.1)
    - tried to install Synapse w/o the devices attached.

    When I put in the DU, it notifies me that it has an update ready and when installing this, it freezes when it is near 50-65%.

    I have found an article that told me to kill an process (regvr32) but that doesnt work.

    Does anyone know how to solve this?
     
  2. FatKidWanderer

    FatKidWanderer Well-Known Member

    Hi there, @Breuert! Did you try temporarily disabling your Windows Firewall or anti-virus program on your computer?
     
    Breuert and T2Pronto like this.
  3. Breuert

    Breuert New Member

    No I had not tried that before, I did now. Thanks a lot! Problem solved.
     
  4. FatKidWanderer

    FatKidWanderer Well-Known Member

    You're welcome. Feel free to reach out to us if you still have any issues.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >