RAZER BLACKWIDOW ELITE Volume Wheel Problem | Razer Insider

RAZER BLACKWIDOW ELITE Volume Wheel Problem

  • 17 July 2020
  • 5 replies
  • 3697 views

Userlevel 7
Hey guys, I wonder if you guys (RAZER BLACKWIDOW ELITE users) have the same problem as mine.

My volume wheel did not functioning well. When i scroll it fast, my volume will always stay at the same point even if the number change like +1 to +2 (when I'm scrolling it) but it will end up at the same point. So, I have to scroll it slowly like click by click sound to volume up and down. But sometime its not accurate. For example, volume will go up +2, +5, +6 like that in 1 click sound.

Do you guys had the same problem ? How do you guys overcome this problem ?

*Sorry for my bad english 😂

This topic has been closed for comments

5 Replies

Userlevel 1
Hi,

I have similar experience lately, my volume dial does what it wants.
Sometime when i roll it up, it goes down instead and when i roll it down, it goes up, in some cases it jumps two or three iterations at the time.

Not sure, but most likely i will send it to Razer for warranty as dial is something i constantly use.
Userlevel 1
make sure windows update didnt randomly change a volume increment setting.... it happens at the randomest times.
same problem here, this post highlights it
/razer-blackwidow-elite-volume-wheel-problem.65040/

how can i check if windows update changed volume increment setting?
Userlevel 2
I can confirm that this is in fact a mechanical issue, although I disagree that oxidization is the problem. I had this issue out of the box on my new Black Widow Elite. Having owned many razer products (sometimes you get one that works on the first go) and other keyboards with similar mechanisms, I immediately tore down the keyboard to assess the issue. Instead of dust or oxidization, the potentiometer had been treated with what looked like lubricating grease, though a very thick veneer of it. Simply removing it with IPA solved my issue. While I do believe throughout the ownership of one of these keyboards that liquids, dust, and other contaminants will cause the same issue to eventually arise, it didn't account for the problem mine had out of the box. It is possible these units are assembled with lubrication to act as a bearing between the potentiometer and the disc and eventually, like my unit did, the lubricant builds up in certain areas and causes the pins to push away from the disc. If someone has this issue out of the box, ask for an RMA, unless you are confident enough to remove the grease yourself. Some people may never have this issue because perhaps the lubrication is very minimal. My unit had quite a bit.
Thanks for that response and your experience, because that is how I learn and we as a RAZER COMMUNITY can and will learn and then change, fix, invent, and apply the correct and most efficient materials, hardware, software, and much more. I have the blackwidow elite as well, and though it isn't my everyday keyboard currently I do remember clearly that I had many issues with the media dial and it's other two keys, and though it and I am not certain this is the issue with mine, I will go in the keyboard and try to correct what ever is wrong with it, THANKS AGAIN FOR THE UNIQUE, IN DEPTH, INFORMATIVE, AND POSITIVE INFO!!!