DEATHADDER V2 ISSUES | Razer Insider

DEATHADDER V2 ISSUES

  • 12 May 2020
  • 6 replies
  • 183 views

Hey Readers,

I bought a Deathadder v2 and it's not recognized by my motherboard when I power up my pc. I constantly have to unplug it or else I get a black screen and a B4 error.

Also on my mac Synapse 2.0 is not seeing it at all.
PLEASE CONNECT A RAZER SYNAPSE ENABLED DEVICE.

I want to mention that i've tried clean uninstalls, settings in bios regarding APM configs and ErP ready > Disabled but to no avail.

Is the mouse faulty or did razer make this one a pain in the neck?

This topic has been closed for comments

6 Replies

ARMOR_152
For the 1st question, did you try it in a 2.0 USB port? It usually doesn't matter but might be worth a try.
2nd Question you might be out of luck, The Deathadder V2 only uses Synapse 3 and Synapse 3 isn't supported on Mac.

Yes I did.
I might be that unfortunate but at the same time it doesn't explain why I cant boot with the damn thing plugged in. It's super annoying even on windows, forget about the mac.
Hi all,
i have similar problem.
My mouse (deathadder v2) doesn't start with windows 10.
I have to plug out/in to start up.

For now I tried to turn off an usb power saving and cheked that, usb legacy in bios is on.
MB - Asus Maximus 8 Ranger

Im waiting, what support will say about that.
Userlevel 7
For the 1st question, did you try it in a 2.0 USB port? It usually doesn't matter but might be worth a try.
2nd Question you might be out of luck, The Deathadder V2 only uses Synapse 3 and Synapse 3 isn't supported on Mac.
Userlevel 7
Ya that is weird, do you have any other PC's you could boot with the mouse plugged in? At least then you could narrow it down to the mouse or your PC. I'm guessing you have your motherboard BIOS up to date, that shouldn't matter though either...
Userlevel 3
My DA Elite has kinda poor build quality.
The rubber grip on the right side of the mouse peeled right off, just a year into use.

And i can't glue it back on.
ARMOR_152
Ya that is weird, do you have any other PC's you could boot with the mouse plugged in? At least then you could narrow it down to the mouse or your PC. I'm guessing you have your motherboard BIOS up to date, that shouldn't matter though either...

I only have my wife's laptop that I can try.I don't know if my bios is up to date but i dont like messing with it since it bricks sometimes.

Stiweno
Hi all,
i have similar problem.
My mouse (deathadder v2) doesn't start with windows 10.
I have to plug out/in to start up.

For now I tried to turn off an usb power saving and cheked that, usb legacy in bios is on.
MB - Asus Maximus 8 Ranger

Im waiting, what support will say about that.

Yeah i got the exact same issue and even tho i double checked the power saving in bios it's still a big issue. I thought it's a faulty mouse but i guess we're at least two facing the same exact problem.
Lately I'm facing another issue where i cant reconfigure my mouse in Synapse 3, it doesn't even change sensitivity when i'm tapping the upper buttons. This shit sucks balls man.