Orochi v2 mouse not moving but buttons are working | Razer Insider

Orochi v2 mouse not moving but buttons are working

  • 12 January 2023
  • 5 replies
  • 773 views

Hi,
I've just bought Orochi V2 and got issue with cursor not moving at all, while buttons are working. I tried to troubleshoot it in a lot of ways: reinstalling, updating drivers, changing batteries, surface, reinstalling razer synapse, cleaning glass below sensor.
Any idea can i do with this?

EDIT: tried both usb receiver and bluetooth mode.

5 Replies

Userlevel 7
Badge +1
Do you have latest firmware installed? https://mysupport.razer.com/app/answers/detail/a_id/4525/~/razer-orochi-v2-firmware-updater-%7C-rz01-0373
Also did you've tested it on another PC (without Synapse installed)?
I did test it on other PC and it still didnt move. Also there is no light from sensor.
Can unscrewing and screwing to recconect sensor help and can it void warranty?
I've updated firmware with link you gave, but i didnt change anything.

Hi,
I've just bought Orochi V2 and got issue with cursor not moving at all, while buttons are working. I tried to troubleshoot it in a lot of ways: reinstalling, updating drivers, changing batteries, surface, reinstalling razer synapse, cleaning glass below sensor.
Any idea can i do with this?

EDIT: tried both usb receiver and bluetooth mode.

What happened.. please give an update... I'm facing the same problem.. nothing seems to work..! Did you get a replacement..or something else.!??

My Orochi V2 is brand new, just opened the box an hour ago, All buttons are working but the cursor is not moving. Already tried it on 2 computers, one with and one without synapse. Also updated the drivers and tried other batteries I have.

Reply