Razer viper v3 pro problem | Razer Insider

Razer viper v3 pro problem

  • 1 May 2024
  • 4 replies
  • 384 views

HI ,A few days ago I bought a Razer viper v3 pro and every time the mouse comes out of sleep mode or I unplug the Razer dongle and plug it in again it lights up white on the mouse for 3 sec and then red for 3 sec and the mouse is charged to 90%. I made a video of the whole situation here is the


This topic has been closed for comments

4 Replies

I have the same problem, haven’t found a solution or reason however; gonna see if I can get in a chatline with Razer support, will update here

I have the same problem, haven’t found a solution or reason however; gonna see if I can get in a chatline with Razer support, will update here

Ok I feel dumb, the color that displays after the white is your DPI setting, I only have 3 DPI presets and they are represented by 3 colors- first DPI is red then green then blue and you guessed it, the DPI I use is on red so thats why it displays red after turning on, when switching to DPI 2 is displays green and so on

Hi john1san,

Your Razer Viper V3 Pro's indicator LED blinking red twice repeatedly signals a low battery (under 5%). If you attempt to charge your device, does it show that it is charging, or is the % stuck? To identify the issue, ensure the mouse is connected directly to your computer, not a USB hub. Additionally, update your device firmware here. Should you need further assistance, please PM with your device serial number and a short video of the problem. Upload the video to any online drive listed in this link. All the best!

 

*Thread locked to curb conversation to PM.

I have the same problem, haven’t found a solution or reason however; gonna see if I can get in a chatline with Razer support, will update here

Ok I feel dumb, the color that displays after the white is your DPI setting, I only have 3 DPI presets and they are represented by 3 colors- first DPI is red then green then blue and you guessed it, the DPI I use is on red so thats why it displays red after turning on, when switching to DPI 2 is displays green and so on

Hi Anti_takenID,

Please refer to pages 6 and 7 of the Razer Viper V3 Pro user guide here to check the device LED indicator for your reference. Feel free to PM me with your device serial number and a short video showing the issue so I can assist you accordingly. Kindly save the shareable file via Google Drive listed in this link. Thank you!

*Thread locked to curb conversation to PM.