Viper Ultimate becomes unresponsive occasionally when dongle is plugged into dock | Razer Insider

Viper Ultimate becomes unresponsive occasionally when dongle is plugged into dock

  • 12 August 2022
  • 1 reply
  • 1406 views

So two days after I got my mouse it started to occasionally get unresponsive at random. This only happened on wireless but eventually I realized it only happened when the dongle was plugged into the dock but if it was plugged into my laptop it worked just fine. What also happened was that when I used it wired for a few minutes up to a few hours it would work normally. This problem would go away but the next day or later would go away.

Things I've tried

Dongle line of sight
Clean ports and cable
Cleaning sensor
Resetting mouse
Updating driver
Making sure cable is plugged in
Firmware reset

This topic has been closed for comments

1 Reply

I had this problem popping up around 1-2 months ago after having bought the mouse more than 1 year ago. The problem gradually became bigger as it would disconnect/reconnect. My fix went as such down below

You should check if all the problems fade away by completely closing/shutting down Razer Central, Synapse etc. More or less all razer apps. If the problem still persists its probably a windows connection issue where its been corrupted in some way.

For this part below u will need a second mouse, but make sure to not uninstall that second mouse as the entire process might have to restarted as windows would do a new USB connection reading after plugging the 2nd mouse out and in again. If u want to be 100% safe while doing this. Create a system restore point if anything somehow goes horribly wrong.

If so, download CCleaner, reset the mouse and dock and uninstall razer and everything along with it. Then you can plug out every other USB connection except for ur razer peripherals. Enter "Device Manager" and uninstall the Generic USB Hub and USB Composite Device that belongs to the razer peripherals. Then u uninstall the razer Dock/Mouse from each of the section Mice and the section Keyboard. Now u should run CCleaner and a registry scan/fix. When it prompts for a backup, do it. Just in case u have other sensitive things that might get fcked up in the process so u can revert with that registry file or the system restore as mentioned earlier.

When the entire process is finished, restart ur PC with the razer peripherals unplugged. When its booted up, plug in the mouse first and wait until razer prompts its own software download. When the software is downloaded, wait and make sure that the razer mouse works as intended and that it shows up. Now plug in the Dock separately and wait for it to show up and work as excepted. Now the mouse can be plugged in with no issues for a few months without anything yet to happen from my own experience. Only the Razer cloud savings should pop up if any information was saved in some way. If something else than the cloud also came along to the new fresh install, then some razer software data remained on ur PC which might make the same problem reappear.