Core X Chroma driver problem | Razer Insider

Core X Chroma driver problem

  • 9 June 2020
  • 1 reply
  • 9 views

I'm going to throw this out there and see if anyone knows anything about this. I recently purchased a Core X Chroma and the new Razer Blade 15. The laptop has the Nvidia RTX 2080 Super Max-Q. The card I currently have which I put into the Core X Chroma is the GTX 1080. I didn't that because my monitor has a DVI connection and the newer cards no longer have DVI support on them.

The Core X is marketed as a plug-and-play eGPU. The problem I have though is that when I connect the laptop to the Core X, everything works fine. However, when I disconnect it I have to reinstall the Nvidia graphics drivers for the laptop. When I contacted support, they basically told me that's just how it is. You'll have to reinstall the drivers every time. Well, that is certainly NOT any kind of plug and play compatibility and the GTX 1080 IS listed as a compatible card for the Core X Chroma.

Has anyone else encountered this issue? Is it a matter of having a desktop card for the eGPU that's too old? The GTX 1080 and the RTX 2080 both use the same graphics driver according to Nvidia's website. So it's not a matter of one using older drivers than the other. I feel a plug and play situation should NOT require having to reinstall graphics drivers every time you use it. Are there any thoughts on this or advice on how to proceed? I would appreciate the help. Thanks!

This topic has been closed for comments

1 Reply

Userlevel 7
Sounds like the system confused recognizing new hardware and detect it as new device that needs new hardware commons issue with egpu setting with laptops that has dedicated gpu, try to disable 2080 super maxq before plugging in. There was actually software for that called gpu switcher but unfortunately it works apparently only till Blade 15 2018, didn’t work with stealth 2019 and I heard Blade 15 later model as well, so atm best thing to do unfortunately only manually doing that. Hot plug (plug and play) is also new features on windows, but I never get it works properly both GPU driver are always crashing resulting similar problem like yours.