Need to unplug and replug the dongle when starting PC for Kraken v3 Pro to connect | Razer Insider
Question

Need to unplug and replug the dongle when starting PC for Kraken v3 Pro to connect

  • 18 August 2023
  • 12 replies
  • 599 views

Userlevel 2

Need to unplug and replug the usb dongle when starting Windows for Kraken v3 Pro to connect. Every day. On a $200 headset.
Tried all the USB, USB2 and USB3 ports on the machine. It does always the same.
The pairing utility works but it doesn’t fix the problem. The next boot it goes back to the same problem. 

This level of incompetence on a product of this price tag is infuriating. 🤦🏻


12 Replies

I completely agree, I got the headset last week and I really like it, but it’s absurd to me that it has such an issue.

Researched possible fixes for hours, but nothing works.

In my opinion this issue has to be fixed asap...

same here

Userlevel 2

After many back and forth emails with their so called ‘support’, they only answer with a robotic offer of an RMA, even when it has been already stated by MANY other customers with the same problem that they did an RMA and it DID NOT SOLVE THE PROBLEM:
 

 


I think this is a problem with the dongle and Windows 11. Something they need to fix with either a firmware update or new dongles. But they don’t know how to fix it yet. So our only solution is to keep pushing so eventually they care enough to give this bug priority.

Meanwhile, the Razer evaluation on Trustpilot is atrocious: 
https://www.trustpilot.com/review/razer.com

And I already added my case to it:

 

Well, I am on Windows 10 and have the same issue, so I doubt it’s OS related

Userlevel 2

So, this being a Windows 11 issue is out of the way. Good to know then.

I have the same problem as you guys. And I didn’t have this issue on my Nari. Very disappointing to buy an even more expensive headset just for it to work worse than one of their cheaper ones I’ve bought years ago.

I have the same issue on Win11. It did go away for awhile but came back after I did some driver updates to my mice and synapse… so odd. 

Userlevel 1

Same issue here after updating to Synapse 20231129.

Userlevel 1

Happy to report that 20231208 fixed it.

I am having same issue, very annoying!

It was working perfectly for me until a couple of weeks ago. Need to disconnect and reconnect dongle every time to get it to work, which is a pain because I bought this for video conferencing, not gaming. Tried uninstalling/ reinstalling drivers, updating framework, using the included usb-A to usb-C adapter, none of it worked.

Maybe it was a windows update thing? I am running on windows 10. It is very weird that it was 100% fine and then out of nowhere it just started to malfuncion.

Anyone found a fix for it?

Hello guys,

Breaking news from my side! :D
I was having a back and forth conversation with the razer support team investigating the issue (they contacted me some weeks ago) and when nothing seemed to work out they suggested reinstalling/repairing Windows.

Ironically, an another issue happened to my copy of WIndows and had to do it.

After doing it I decided to give it a go and it worked!


I suggest trying this last fix to see if it will work for you as well.

(My windows is Win 10, with latest update).

Reply