Plugged in, Not Charging | Razer Insider
Solved

Plugged in, Not Charging

  • 16 April 2023
  • 52 replies
  • 6347 views

Hi there,

The problem I'm having right now is that the computer won't charge. However, the LED indicator on the power supply is on. In other words, when the battery runs out, I can no longer turn on the computer and use it.

It is because when I connect the power supply to the computer, there is no response at all.

 

I heard someone said maybe the software(Windows 11) problems !

I have tried to delete and reinstall the batteries driver from the windows 11 system device, but it still can't solve the problem.

What should I do?

 

Attached is my laptop information.

Microsoft Windows 11 Home

version(10.0.22621 Build 22621)

Razer Blade 15 Advanced Model (Mid 2021)-RZ09-0409


Many Thanks

 

icon

Best answer by mjcouchman 18 April 2023, 14:35

View original

52 Replies

Userlevel 3

Have you got a USB 3 charger (<100W) you can try? I have the early 2021 RB15. You can plug into the left hand side USB 3 port, or the right hand side TB port. I had the same issue/symptoms you have. I picked up a USB charger for < $50 brand new at a local PC shop. Once I plugged in the USB charger, the laptop started charging off both the main charger, and the USB one. I'm not saying this will resolve your issue as well, but at least you may get a charge for now.

Thanks for the reply, let me try to buy a usb charger. Does it needs to set anything at the BIOS first?

Userlevel 3

I got a J5create JUP2290 100W PD USB-C Super Charger that I keep as a spare. Nothing needs to be done in the BIOS.

Thx man, I will buy it for testing

According to your method, it works right now. I can see the charging status through Windows 11, but there is still no indicator light (the green light) showing on the laptop. Anyway, you saved me.

 

the quality too sucks, I bought it and used it for less than 1.5 years.

 

Userlevel 3

Great to hear you are charging again! It will take a while to charge, and Synapse will complain about not getting enough power. Leave your 230W original power supply plugged in as well as the USB charger - it doesn't hurt them; the unit auto switches.

 My experience with my RB15 is so far similar to yours, and my issues also started after having the unit for about 1.5 years as well. I have the Razer TB dock plugged in most of the time for work, which provides 65W through the TB port. Occasionally, my main power adapter will stop charging. I cant say why; it could be when its under load (I have noticed its sometimes after heavy graphical games, but again, not always), or maybe gets really hot. The TB dock will then keep the laptop charging, or at least the battery wont drain anymore. After some reboots, it will just start charging again from the 230W adapter (which gives the laptop full performance). 

I did notice this started happening around the time I installed a 2nd M2 SSD on top of the existing factory M2 drive. I also installed Windows 11 at the same time, so I cant state it was either of these things that caused the issue. I did revert back to Windows 10 for some time, and it seemed to perform okay. But then I went to Windows 11 again, and the issues started happening again. I still cannot state it was Windows 11 that is the cause. 

Would be interesting to see if you have done any of what I have as well (the M2 drive I mean, as I see you have Windows 11 already!). 

My current state is that my battery ended up swollen (like a large number of others have experienced). I removed it 2 weeks ago for safety. The laptop ran fine off the 230W with no battery in it for a few days, but then stopped providing power once again, and the 65W and the 100W TB/USB chargers possibly aren't enough to power the unit on (maybe, unsure on this, but neither would allow the unit to boot at all). I have purchased a new 3rd party battery (same manufacturer as the Razer battery) that arrived 2 days ago, and it was swollen! Awaiting on the company to provide me a replacement. 

I am considering building a desktop to replace the RB15, but it just hurts considering how much I paid for it, and the short lifetime of the unit. So I know how you feel.

So for now, I have taken my trusty 2014 RB17 out of the cupboard, and I have been using that, which has not failed me! 

I will let you know if the new battery changes anything, but I am not expecting it to.

 

Userlevel 3

Also, the Razer guys on this forum are very active. If they see this post, they may be able to help you with an RMA. 

I have the same problem, I don't know what I do??? 😞

Userlevel 3

@Omer-Hussein Probably best to start a new thread detailing your model and the issues you have. If its the same as the above, try the solutions already provided first.

@alfielui Thanks

I also got the same Problem for Razer Blade 17 late 2021 (RZ09-0406).

I try charge it with 65watt type c charger for few minute and somehow 230W charger working again.

My problem also occur in windows 11 then I try downgrading to win 10 the issue not comeback.

Still not sure it software Issue or hardware Issue.

 

I also got the same Problem for Razer Blade 17 late 2021 (RZ09-0406).

I try charge it with 65watt type c charger for few minute and somehow 230W charger working again.

My problem also occur in windows 11 then I try downgrading to win 10 the issue not comeback.

Still not sure it software Issue or hardware Issue.

 

I also have this model: Razer Blade 17 late 2021 (RZ09-0406). I attempted an RMA process and they sent the laptop back with the exact same charging problem after claiming it was fixed. Plugging USB does seem to “jumpstart” the battery into charging like others have suggested. I still am unsure if this is software or hardware related but I will try to send back for a battery replacement and see what happens. Interesting to note the issue persists on Windows 11 for you and not 10, as I have the opposite reaction (does not work on Windows 10).

Also: BIOS Update 1.06 installed, no changes.

Same problem for the exact same model I’ve also notice that the charging break whenever there is a new synapse update may be a contributing factor but super annoying issue

Having this same issue! Razer Blade Pro 2021 0368 model. Had the device for just over 6 months, was fine till about 2 months ago, adaptor is lit green, it will charge for maybe 2 seconds before going back to battery mode and not charging until it's unplugged and plugged back in again to only charge for 2 seconds. I left the laptop for a couple of weeks and then it started working again fine, however alas yesterday it's stopped charging again. The support process is far from helpful (check the socket it's plugged into has power...) All that jazz, clearly looking online this is a recurring and consistent issue across RB models and years however there isn't a "fix". 

I do have the same issues with my RZ09-0330x (early 2020). Using Win11 too. But unfortunately the provided workaraound is not working in my case -.-

 

It would be great if Razer support could provide some official feedback on this topic, it seems to be an more general issue...

I'm having this same issue. As a previous poster on this thread has pointed out, this is clearly a common issue. Razer support seems to shutdown threads and move them to PMs pretty quickly so they seem to be playing damage control… who's to say.

Anyway, I have updated the bios to the most recent version and that didn't do anything. I have tried the whole delete battery driver, restart, shutdown for 8 hours while plugged in, power on and drain battery, recharge dog and pony show with no real impact. My power adapter LED indicator is lit and is putting 19.05 Vdc through the central pin unloaded, which checks out. Perhaps this is windows, but it doesn't track since these reports are coming at different times (across 2 years) on specifically razer blade computers.

There is a software type issue here and you would expect a patch for something like this. Let's see some official responses! This is CLEARLY a razer blade laptop issue that is widespread.

Userlevel 1

I have the same issue. It was not occuring until I upgraded to Windows 11. It did not start right away. I replaced the adapter. I tried a friends stock adapter that worked on his same laptop and outlet. I replaced the battery. I tried all of the time wasting troubleshooting steps mentioned here. The only thing that works is to: 

  1.) disconnect all chargers

  2.) connect a 100w usb charger with appropriate cable 

  3.) connect the AC power adapter

 

The AC adapter does power the Razer and even without the USB C connected it will not drain the battery, even while gaming. I paid over 4 K for this laptop and sunk hundreds into repairs and the lack of support or even acknowledgement from Razer is frustrating. I even did a fresh install of windows (11). Is the next step to hurl it through the window of Razer HQ as a junk overpriced product?  
 

I have the 2021 Razer blade 15 advanced with 32gb ram, RTX 3080, 60Hz 4k OLED touchscreen, i7 processor, 1TB SSD and came with windows 10.

Same problem here. It accoured around a year ago but fixed itself. I did nothing specific.

As you can see the problem is coming up again in the last days/weeks, maybe a windows update is causing this trouble?
However, never Razer again :-)

Userlevel 1

Same issue here with an Early 2021 Blade 15 Advanced QHD x0368.

I contacted Support and they ask all this battery log information and laptop data but never suggest a proper fix. I also think they are clearly avoiding admitting to this issue. They should consider putting a team together and fixing these issues. Future buyers beware! All of the other cases noted above and in other threads have yet to be formally addressed by someone with authority at RAZER.

@Razer Admin When will we receive a helpful response from the Razer organization? Many thousands spent by consumers here for bricked laptops. Thought we would find help from the manufacturer in this thread?.. 

Also the 100W USBC is not a real fix when this laptop demands the 230w to function at its full potential. 

If I wanted a basic laptop I would have spent less on something else.

We need real results from your research team and we have needed it for years now…

 

Where’s the response?  

This is happening to me too (RB 14, 2021). It started happening this week, and it only charges through USB-C. I bought it only a few months ago. I de-installed drivers and it did not fix it. 

 

It will recognize the 230W charger momentarily and then stop charging, but it works with USB-C.

 

@Razer Admin  

I have the exact same issue with a Blade 15 Advanced 2021. 
I posted all of my findings here:
 

 

I am having the same experience with my RZ09-0367CGD3.

Power supply bought new, everything updated the instructions from razer gone through hundreds of times I'm really really pissed. The device costs over 2 thousand euros and I have it just under 2 years. I'm done with the f thing.

 

Great that the support here takes so great sympathy. Better continue building keyboards 

Mine also started with the issue again this week 

could be a software issue more than anything

I am having the same problem with my Blade 15 Advanced, RZ09-0367CED3.

 

Razer, can you do anything?  I need this laptop for an event tomorrow and I can't get the battery to charge, or run it directly off the adapter.

 

A USB adapter made the computer charge for a few seconds, then it stopped after I turned it on.  Now neither the 230W charger nor the USB charger will work.

Just started experiencing this today. It wasn’t the first time I had trouble with charging it, but the first time that I’m getting the plugged in but not charging thing. Would really like to know if there is a solution for this. I need this computer for work

Reply