Razer 15 2019 base model fan running even when the PC does barely anything | Razer Insider

Razer 15 2019 base model fan running even when the PC does barely anything

  • 2 October 2019
  • 5 replies
  • 5 views

Dear support,

I just received a brand new Razer Blade 15 2019 base model (15.6 Inch, 144 Hz Full HD NVIDIA GeForce RTX 2060, Intel Core i7-9750H, 16GB RAM, 512GB SSD, Windows 10)

After 24 hours trying a few usual tricks I can't understand why just getting my emails with outlook will start the fans, quite loud. The keyboard gets warm pretty fast too, what can have that unit heat so fast??

I need something silent to do basic work, and have no problem with noise when it becomes intensive. We are far, far from ideal and I wonder if that product is just not for me. I'm used to laptops able to switch to embedded graphic card to do office work, is the Blade doing it?

Is there any tweak that could be done to improve on that aspect of should I just get something else?

Also, oen of the keys was broken (and the backlight shows it very well), is it possible to get a replacement D key or, again, should I return the product immediately?

Thank you.

GP

This topic has been closed for comments

5 Replies

I should add that there are many things that I like in that product, if we can make it work, I'm willing to keep it.
Userlevel 7
There are a few things you can try to control the temps and the fan rpm but because there is a broken key, you might as well skip all that for now and get this repaired/replaced.
Hi Caziel, thank you for your answer.

Let's put it that way: I have one month to return that product for repair, but if I can't get it to operate silently, i'll ask for a refund.

So, can we try working on the fan noise? :smile_:
By the way, I already switched off Turbo boost and it helped a little, but not enough.

I also installed hwmonitor and I don't see stupid high temperatures, but the body is still quite warm and the fans running. I have a Dell XPS 15 and several MB Pro to compare the Razer too and working alongside, again I have no problem with noise under heavy load, but to write an email, come on...
I wanted to give a feedback.

Had another unit and been working with the support (nice people), ultimately the fans keep running at all time, even with a processor load under 5% and I try to get used to the constant noise.

Battery operation is silent (up to a point) so that's good, would have been great to get something similar when on PSU, even with lowered performances.

I am using an external (34" 4K) monitor, so I guess the Nvidia graphic card is always on and doesn't help with heat, but the laptop itself is never really hot, just a bit warm.

i suggested to the support the creation of a "silent mode" with degraded performance in Synapse, maybe some day it'll exist...