Razer Nari Ultimate rapidly disconnecting | Razer Insider
Question

Razer Nari Ultimate rapidly disconnecting


Userlevel 3

Having the same issue as many others here - Razer Nari Ultimate worked fine for a long time now all of a sudden is rapidly disconnecting/reconnecting on PC/PS5 - causing playback issues and of course forcing me to use 3.5mm jack - reached out on twitter troubleshooted everything from the recovery tool to having my case escalated to “advanced support” but its been 5 days without reply

USB ports work for anything else just the headset keeps cutting out and its infuriating - please assist as this is my third locale for support


114 Replies

same issue here, and the worst part is i have the pewdiepie razer nari ultimate limited edition.

before this issue appeared where it wont connect/pair at all i had issues with my left driver not working and cutting in/out. i susspect its was something related to the battery but i could be entirely wrong and magically one day just started working again. then about a month later i get this lovely message as my headset dissapears from the sound options on my pc (device couldn’t be detected by pc, could be a defective device} or something along the lines. and just to throw in a cherry on top of the cake of problems this headset has, anyone else have a interesting kinda eletronic/burnt smell when you give the earcups a whiff or is it just me? ive had the headset since i think begining of 2020 hard to remember but youd think 3 years of owning it, the smell would go away if it were “packaging/new smell” which i confirm it isnt, its clearly burning. in the years of owning it, its honestly been nothing but a headache to be real, a great headset but just nothing but troubleshooting and wondering if my money could of went to something a bit more reliable and less buggy.

 

HELP

Hi I am having the same issues My Nari Ultimate keeps disconnecting and reconnecting. Everything is updated even razer synapse.

This is happening to my headset as well connects and disconnects over and over

Userlevel 2

Razer just broke all our expensive Nari Ultimate headsets with a recent Synapse update as the Synapse software appears to be causing the issue with the headset.

Likely they did this to incentivise us to buy their new Kraken V3 or Blackshark V2 headsets and if those end up lasting too long they will just break those with another Synapse update so we go out and buy their next headset they came out with.

Has anyone found a way to fix the disconnect reconnect issue?

Hi I am having the same issues My Nari Ultimate keeps disconnecting and reconnecting. Everything is updated even razer synapse.

 So I am pretty sure it is a razer sypnase update issue. Going to attempt a uninstalling Sypnase and use my headset without the app, hope it works.

Just to let anyone know, my gfs headset has been having this issue so i swapped my headset with hers, her headset didnt keep disconecting when plugged into my PC, and my new one started disconnecting on her PC. SO its not a headset issue i believe.

Hi boys, i have given up fixing this issue, i bought new dongle from china, used paring utilities to the new dongle, same problem still exist. Replaced battery to brand new high capacity battery, nothing change except weight.

 

Some of you mention to use it without sypnase,  it will still happen. Fresh windows, ps5(impossible to have sypnase), even ubuntu.

 

I own this headset since 2019. I don’t think is related to hardware, more like firmware that broke our headset. 

 

summary, don’t spend money to replace the dongle as it is a waste, solution for now is only wired mode.

 

p.s battery upgrade mod is worth it if your headset still works wirelessly

I just fixed this issue by turning off that “Power saving” option, instead of the headset reconnecting and disconnecting every 2 minutes, it stays connected for me start to finish. Hope this helps any of you

I just fixed this issue by turning off that “Power saving” option, instead of the headset reconnecting and disconnecting every 2 minutes, it stays connected for me start to finish. Hope this helps any of you

 

Didn’t work for me 

The problem remains the same

I don’t know what happened but awhile ago it keeps on disconnecting and reconnecting then right now, I can see a blinking blue light. My Nari Ultimate is not detected in synapse anymore. Is there a problem now in the receiver of the headset? I’m not sure. I’m also experiencing the issues that you encountered before.

As of today mines is now doing this, it’s not even trying to connect to my pc now and it was working fine up until a short while ago. Is there any fix?

Userlevel 1

Same problem here but my pc still can’t detect it when I connect it wired with the 3.5mm cable. I have no idea what I am  doing wrong

I am experiencing the same issues! Could Razer please contact me?

It’s highly likely that the dongle is defective. Please PM me your case number so I can coordinate with the relevant team and check our options. Thank you!

I am also having the same issue. The last 2 nights I’ve spend 6 hours each time trying to fix it, i don’t know if it’s windows 11 related but I am close to throwing it away…

Happend to me today.
Yesterday everything was fine, but i started my pc today & since then, just constant disconnect & reconnect.

Synapse was up to date( even deinstaled & reinstaled everything), sound drivers also, so no “new” update stuff happend since i turned off my pc & started it today

This morning I was on my computer and had no issues with my headset, then there was an update today and now I’m having this issue. I’m wondering if it has something to do with the drivers but I have no idea how to fix it. I also completely reinstalled synapse and still not working

For me, both the usb dongle and usb cable don’t work after the update, but there is a second wire in the box that plugs into the audio input and outputs. If you have an audio and mic splitter, you can use that to plug it into your computer and it will work like a wired normal headset. 

 

The volume wheel on the side of the headset does still works without the software, but since the mic mute button is software related that doesn’t work. I love the Nari, its so comfortable and at least I managed to get it to work wired but hope they fix the software issue

I`m facing the same exactly issue with my headset, already sent you a PM @Razer.Zionzedd 

I'm having the same issue, please help me

Well looks like I am having this issue as well, any updates on fixes? 

Exact same problem here. Occurred out of the blue. Reinstalled drivers etc. 

Seeing how this thread is over 2 months old and seemingly no solution has been offered  - Correct me if i’m wrong but I’m quite convinced that when @Razer.Zionzedd azer.Zionzedd asked for S/N to “check available options” he is most likely just going to check if it’s within warranty.  My product is out of warranty, yet has no physical damage and “broke” completely random without any physical contact (the receiver just sits in the usb, there’s nothing wrong with the port..) 

Add to this, the amount of people itt with the same problem - this is either a sw issue (another case of synapse being a terrible piece of garbage) or it’s an embarrassingly obvious case of planned obsolescence.

 

Surprise me @Razer Admin  - though I doubt this will happen. Having owned countless of razer products, ever since the first boomslang was released in the UK, yet have never really been acknowledged by razer as an appreciated customer. nor received the support required as of the past few years, I’ll be changing peripherals provider going forward.

 

No more of this, goodbye razer.

i have the same issue, i just closed the synapse app and all razer assotiate programs and there is no progress. i feel like the bluetooth just went broke

Any update on this? Been a long time and still the same issue.

Reply