Synapse 3 software OS requirements | Razer Insider

Synapse 3 software OS requirements

  • 6 May 2019
  • 1 reply
  • 134 views

I was trying to install synapse 3 software on computer with the plain windows 7 installation. It appeared that is is impossible. Please see the picture below. Is it by design or it is because it is in beta state? Do I really need service pack 1?

Thank you!

Alex

This topic has been closed for comments

1 Reply

Userlevel 6
We strongly advocate using the latest version of Windows 7 (64-bit) with all service packs and updates. Older versions of Windows may not have the libraries that Synapse 3 requires.