My Razer Blade 15 BaseModel isn't detected by Synapse 3 | Razer Insider
Question

My Razer Blade 15 BaseModel isn't detected by Synapse 3


For whatever reason, Razer Synapse refuses to detect my device? Initially it did but after multiple refreshes due to regular PC updates for antivirus systems blah blah, it wouldn’t pick up again.

I’ve tried completely uninstalling Synapse (3 times), I’ve rebooted the laptop once of which I had some more hope until the final hurdle before installing Windows 11 on it to where it lost detection for whatever reason.

I’ve watched the video provided by Razer and ran multiple diagnostics checks (on both Windows 10 and 11), I feel like I’ve exhausted all my options! I need help ASAP, thanks in advance.


12 Replies

Userlevel 7
Badge

If you’ve installed Valorant, then Riot Vanguard anti-cheat software can cause device to be not detected in Synapse software.

Have you done clean reinstall Synapse (including special tool to remove Razer drivers/leftovers), or just simple Synapse reinstall?

I have not installed any Riot game (yet 😂) therefore the anticheat cannot affect it.

For what I have done so far, I have uninstalled it from the task manager once, second time, I cleared it from task manager and went on a hunt on my SSD to clear all Razer files, including Cortex and 3rd time was similar on Windows 11. I saw somewhere to try CCleaner to thoroughly clean the files or something like that; if you have any recommendations just to quadruple check.

I logged in on my alt account, my bad! There is no conflict between Razer accounts, this was another trial as someone suggested a conflict, to which there wasn't.

Userlevel 7
Badge

Try these steps:

  1. Uninstall Synapse
  2. Download & run this tool: https://rzr.to/Tf53xj to remove any razer drivers/leftovers
  3. Then restart your PC
  4. After reboot install Synapse again (as administrator).

Also be sure, that you have latest .net and Visual C++ redist files.

Alright, I will try this!

How exactly do I ensure the latest .net and Visual C++ redist files are installed? Do I uninstall those as well and reinstall them manually?

Userlevel 7
Badge

Alright, I will try this!

How exactly do I ensure the latest .net and Visual C++ redist files are installed? Do I uninstall those as well and reinstall them manually?

You can just download installer, and it’ll detect if it’s the newest version or not. But reinstalling this can sometimes also help.

So I've just done everything listed and it still isn't detecting my device. I am distraught!

I’d like to add that it was working perfectly fine until a certain optional update in Windows settings. I can’t remember what it was but I was planning to do a whole PC restart once I return home to identify which update/file in specific seems to bug my device or Synapse. What do you think of this?

Userlevel 7
Badge

I’d like to add that it was working perfectly fine until a certain optional update in Windows settings. I can’t remember what it was but I was planning to do a whole PC restart once I return home to identify which update/file in specific seems to bug my device or Synapse. What do you think of this?

Windows Updates can also sometimes mess with 3rd party apps like Synapse.

If you remember when it started to be non-detected, then you can go to Windows Settings → Updates, and check update history - there will be update installation date and update number/update name. With this information you can try uninstalling updates one by one (of course restarting system on each update uninstall), and test which could cause the issue.

Alright I will make an attempt to do this; though I have an older model of the Razer Blade 15 (2019 I believe, 1660Ti) with all mandatory and optional Windows updates whilst running fine, which is the skeptical part.

I’d like to add that it was working perfectly fine until a certain optional update in Windows settings. I can’t remember what it was but I was planning to do a whole PC restart once I return home to identify which update/file in specific seems to bug my device or Synapse. What do you think of this?

I just bought a Razer Blade 15 Advanced (2019) through amazon and have the same issue, Unboxed it, windows 10 was on it. I upgraded it and after the upgrade to Windows 11 (basicly still a clean installation of the laptop no other software) the Synapse 3 does not recognise the device anymore. Pc is 1 day old in my hands… So probably Razer will have more of these isues since I still have the product warranty as of yesterday and people will complain. I’ll try to make a live chat with one of the agents this afternoon.

Did you ever solve this problem? Mine has done the same thing laptop not detected in synapse but also the keyboard and RGB isn’t working. Blade 15 1660ti mode 

Reply