Synapse 2 not recognizing Orbweaver Chroma WIN10 PRO | Razer Insider

Synapse 2 not recognizing Orbweaver Chroma WIN10 PRO

  • 1 October 2019
  • 9 replies
  • 186 views

I have a Razer Orbweaver Chroma model: RZ07-0144 connected to a:

WIN 10 Pro - all current updates
Intel Core I7-6700K
16GB Corsair RAM
2 Samsung 850 SSDs in RAID 0 config as main drive
1 3TB Samsung HDD for storage
Logitech G910 Keyboard
Logitech G900 Mouse
.net framework 4.7
Malwarebytes Pro
Asus 28" LED monitor

My Synapse 2 stopped recognizing my Orbweaver 2 this morning. I followed all the suggestions MULTIPLE TIMES, as found in the forums:

  • Remove Razer devices within device manager - restart - Win10 finds and installs again

  • Uninstalled Razer Synapse 2 - restart - download and install newest Synapse 2
  • Tried moving Orbweaver to all possible USB ports

I even formatted and reinstalled Win10 and installed Synapse 2 with the same results. Synapse 2 loads up and asks for me view compatible devices etc. It just will not recognize the Orbweaver Chroma.

Windows 10 sees and installs the device, Synapse 2 won't recognize it as connected - no matter what I try. Any suggestions would be greatly appreciated.

This topic has been closed for comments

9 Replies

Userlevel 5
Hi,
I have a similar configuration. For me, only colors with TESO doesn't work since some days. Remaing seems to work.
Did you try to disable AntiVirus . Malwarebytes to test it ?
Thank you for your suggestion. I just tried disabling Malwarebytes with no success. I'm wondering if the Orbweaver itself is bad now.
Userlevel 5
You can try to deinstall MalwareBytes, and try then with Synapse.
To be asure, you could test on another PC, if possible.
Otherwise only Razer support may help you, than post in the support forum.
same problem since a windows update
Userlevel 7
Hey there! May I ask what version # of synapse you have and your windows 10 build number?
Hi guys.

So I found how to resolve this issue (at least for my case).

1.) Open Control Panel
2.) Open Device Manager
3.) Click the '+' sign for "Keyboards"
4.) Locate and double click 'Razer Orbweaver Chroma'
5.) A window opens, click the 'Driver' tab
6.) Click on 'Update Driver' button
7.) Click on 'Browse my computer for driver software'
8.) A window opens, click the 'Let me pick from a list of available drivers on my computer'
9.) I had 2 options for 'Razer Orbweaver Chroma'. I chose the oldest driver
10.) Click 'Next' and follow any further prompts to finish the installation of the older drivers
Hey, I had this problem a couple of years with the cysonos chroma but apparently they are making more and more devices not supported by synapse 2
Userlevel 7
Badge +1
Remove synapse.
Go to device manager, remove your Razer device (with drivers)
Use CCleaner to cleanup your PC & registry.
Reboot OS
Install Synapse again.

It helps in most cases.
i am having the same issue since Windows 10 forced me to 1909, my Naga Chroma Epic will not recognize and the driver is gone, it wont let me install a non 64 bit driver and i have done everything i can think of to fix the issue, including uninstall and reinstall (with CCleaner and reboot), gone through tech support and more unistalling and reinstalling, trying on different computers (all forced to 1909), plus my mouse has started the dreaded random stuttering lag which is usually what i see before a Razer mouse dies (i have had a original naga and a 2014 naga before my epic)