Synapse won't register game exe after attempting to link it | Razer Insider

Synapse won't register game exe after attempting to link it

  • 3 August 2019
  • 3 replies
  • 112 views

It seems nothing is registering. I just downloaded the new update after getting my replacement Tartarus. I'm trying to link Overwatch to a profile. I navigate to the install directory which is on my E drive and click the exe and... nothing. If I search Overwatch, all that appears in the list is the test realm exe.

This topic has been closed for comments

3 Replies

Userlevel 7
try this:
Open synapse and go into profile module there select device and profile you want to link. Next thing is click on the "Select a game or two to link to this profile" windows will popup then click "ADD" on right upper corner window will change and show files then click on "Browse" windows window will appear there search for game folder in this case overwatch and select overwatch.exe file. Everything shall work.
BlackFireDragon
try this:
Open synapse and go into profile module there select device and profile you want to link. Next thing is click on the "Select a game or two to link to this profile" windows will popup then click "ADD" on right upper corner window will change and show files then click on "Browse" windows window will appear there search for game folder in this case overwatch and select overwatch.exe file. Everything shall work.

That's exactly what I did. Doesn't register.
Userlevel 7
In this case you can try two things. First is repair synapse via add/remove windows panel if this dont do nothing try to uninstall all razer softwere then remove razer folders in appdata and programfiles and reboot pc next thing is download new installer for synapse and install it. Second thing you can also you can try to remove battle.net app from your pc and clear the appdata folder where files will stay after uninstall.