Kraken V3 PRO Charging issue | Razer Insider

Kraken V3 PRO Charging issue

  • 31 December 2021
  • 39 replies
  • 3823 views

Userlevel 1
I can't seem to get this headset charged up completely. I'm using the included cable on a 5V 2.4A USB port. Charged overnight and this morning the LED is still blinking.

On a related note, the Synapse app only shows a tiny battery representing the charged state. How about a percentage (%) indicator?

This topic has been closed for comments

39 Replies

Userlevel 3
rmazzaro
I can't seem to get this headset charged up completely. I'm using the included cable on a 5V 2.4A USB port. Charged overnight and this morning the LED is still blinking.

On a related note, the Synapse app only shows a tiny battery representing the charged state. How about a percentage (%) indicator?


I noticed that mine stops blinking after some time but never lights up green as it should after being fully charged. Also when I replug the cable it blinks again for some time.
No percentage indicator in the app yet. I reached out to Razer Support two weeks ago about this, and they said it's not available. They couldn't or wouldn't tell me if it was coming soon in an update or not. I hope it does soon. I hate not knowing the battery percentage! Spent almost $200 for it and this feature not available! I have the new wireless keyboard and the wireless ultimate mouse, both of these have the battery indicator, so not sure why the headset wouldn't...

My question is can we charge this headset using our phone charger or any wall charger, what is the maximum and minimum power charging requirements? I cant seem to find this information anywhere. Would be nice if I can charge headset using my phone charger so it charges faster then using a 5V 2.4A USB Port on the PC.
Having the same problem. Won't charge fully. Another issue is when I've disconnected the charger cable the battery icon still goes up and down as if it's charging, but it knows it's not plugged in any more, as the lightning symbol disappears when disconnected.

It also gave me issues with Synapse. That got corrupted after a Warzone crash and I had a hell of a time getting it sorted. It seems this headset has issues. If they don't sort it out in the next version of Synapse, I may have to send them back, as they're too buggy for me at that price point.

The THX Audio is also not very good IMHO. Very tinny and the audio cues are off somehow. My Nari Essential headset seemed to be better (albeit massive). So, altogether Razer has some work to do.
Userlevel 3
R3DH0TP0K3R
Having the same problem. Won't charge fully. Another issue is when I've disconnected the charger cable the battery icon still goes up and down as if it's charging, but it knows it's not plugged in any more, as the lightning symbol disappears when disconnected.

It also gave me issues with Synapse. That got corrupted after a Warzone crash and I had a hell of a time getting it sorted. It seems this headset has issues. If they don't sort it out in the next version of Synapse, I may have to send them back, as they're too buggy for me at that price point.

The THX Audio is also not very good IMHO. Very tinny and the audio cues are off somehow. My Nari Essential headset seemed to be better (albeit massive). So, altogether Razer has some work to do.


Got mine RMA'd today, or to be precise, received number and prepaid label for DHL and already sent them back to replace the device. I am sad as overall they are great if i wont count also synapse issues.
I'm currently going through tech support aswell with issues.
Provided the video they requested on my audio issues.

I have the same stuff with charging, doesn't show full and the led indicator seems to have a mind of its own
Same issues with charging, but I'm in the process of RMAing right now for different issues.

After testing out the haptics, I realized that if I switch haptics while listening to any media the haptics go wonky and the headphones start rattling really badly. The only way to fix this is if you stop the music, turn the haptics off, then back on again to the desired level, THEN start the music/media again.

I've tested this on two different PC's and tried both 3.5mm and USB dongle, same results.

It's really a shame because they sound great in general. I'm worried these are being held back by very poor QA and proper testing; this is Razer's only and last chance for me personally. As a side note, being able to see your headphone's percentage is a must, and being able to switch haptics using the haptics button on the headphones must work as intended for $220 (with tax). Cheers
Userlevel 1
I'm really disappointed in the options available at this point. After spending $200 on this headset, it arrived and won't fully charge (defective). I now can send it back for free and be without a headset until ??? OR return the headset (still under the 14 days) and pay $15 to FedEx it back to them so I can get my refund. Disappointing. Is this product really ready for distribution or did we just pay $200 to be a beta tester?
SHOOTIEST
Same issues with charging, but I'm in the process of RMAing right now for different issues.

After testing out the haptics, I realized that if I switch haptics while listening to any media the haptics go wonky and the headphones start rattling really badly. The only way to fix this is if you stop the music, turn the haptics off, then back on again to the desired level, THEN start the music/media again.

I've tested this on two different PC's and tried both 3.5mm and USB dongle, same results.

It's really a shame because they sound great in general. I'm worried these are being held back by very poor QA and proper testing; this is Razer's only and last chance for me personally. As a side note, being able to see your headphone's percentage is a must, and being able to switch haptics using the haptics button on the headphones must work as intended for $220 (with tax). Cheers


Yeah same issue here and I've seen reports of this on a few reddit posts. I'm thinking this and the battery issue can probably be fixed with firmware udpates. I'm going to keep mine for awhile and see how it goes.
Userlevel 3
Wartman
Yeah same issue here and I've seen reports of this on a few reddit posts. I'm thinking this and the battery issue can probably be fixed with firmware udpates. I'm going to keep mine for awhile and see how it goes.


Problem is that this fix with battery/charging issue needs to be either rolled out via fw update asap or fixed by replacing defective device. Headset like this does not know when the battery is fully charged and keeps it charging over and over therefore there is high risk that one day it will blow up or it will die completely. Either way it will not work and you will endanger your surroundings.
Userlevel 7
rmazzaro
I can't seem to get this headset charged up completely. I'm using the included cable on a 5V 2.4A USB port. Charged overnight and this morning the LED is still blinking.

On a related note, the Synapse app only shows a tiny battery representing the charged state. How about a percentage (%) indicator?


I've notified our Support Team and shared this post. Thanks for kick-starting this thread.

For the other and upcoming users on this thread - Please submit a case to our Support Team so they can track all the affected users and devices. I appreciate your cooperation and patience. Feel free to submit a case to our Support Team or send me a PM.
Userlevel 3
Got my RMA today finished and delivered.... it did not solve anything. I highly suspect it is a problem of FW in terms of charging issues, maybe also the poor audio balance
Dino89
Got my RMA today finished and delivered.... it did not solve anything. I highly suspect it is a problem of FW in terms of charging issues, maybe also the poor audio balance


I was worried you were going to say that! Is nothing any better at all? What are you going to do now?
Userlevel 7
Badge +1
Dino89
Got my RMA today finished and delivered.... it did not solve anything. I highly suspect it is a problem of FW in terms of charging issues, maybe also the poor audio balance

It may be also batch problem, that is unsolveable by FW.
Userlevel 3
Casper1390
I was worried you were going to say that! Is nothing any better at all? What are you going to do now?

Yeah after what i read on the internet i was worried as well. It is exactly the same, and razer support this time is horrible. After all the reference they are going from scratch...i dont get it. So i opened new case, i am literally afraid that due to this charging issue i cannot leave it as it charge over and over again. This can harm battery and start fire, im not gonna risk it in my household. Now i think they will not allow me to return it and im gonna be stuck with it...
Userlevel 3
FiszPL
It may be also batch problem, that is unsolveable by FW.

It looks like this new device is somehow new batch atleast serial number is way different. But thats just asumption.
You could be right, but it depends on them whether they allow me new RMA or refuses.
I've been struggling to get mine picked up to be honest! They missed my first collection day because support were too busy to make the arrangements, now their sending me the transport label via email the same day as the package is being collected.... Hopefully DHL don't get here first!
Userlevel 3
Casper1390
I've been struggling to get mine picked up to be honest! They missed my first collection day because support were too busy to make the arrangements, now their sending me the transport label via email the same day as the package is being collected.... Hopefully DHL don't get here first!

In my case i waited for label then calmly prepared the package and then went to DHL "box" which is near and can be used to collect or get packages. And i put it there myself :D

Anyway yesterday i received new RMA number with return and refund luckily, therefore they send label to somewhere in Netherlands. Today i received new email with apology that it was directed to wrong warehouse and they sent new label to send it somewhere in Singapore surprisingly. So hopefully its okay now, luckily the time they were sending it was almost night for me 😃
I have also a problem with charging my headset. For the first month, it was great and everything was okay regarding charging the headset and now I can't charge them anymore. They all the time empty and I can't use them. Do you think that this is some software problem or it is the headset? They are almost 200 and now I can use them. I don't know what to do.
Userlevel 3
veronikaveber
I have also a problem with charging my headset. For the first month, it was great and everything was okay regarding charging the headset and now I can't charge them anymore. They all the time empty and I can't use them. Do you think that this is some software problem or it is the headset? They are almost 200 and now I can use them. I don't know what to do.


Hi Veronika, that is really unfortunate and makes me think i did right choice in my case when i returned it, as it clearly shows that charging is major issue here (some folks did not notice so far that headset is overcharging and killing battery itself) that needs to be fixed asap.
Looks like HW or FW issue that is for sure, and your only option is to create ticket and let Razer handle it. I would also suggest to either create ticket via Customer online support, where you need to explain the issue and tell them to escalate it asap. Or if you create ticket by yourself, immediately contact online support as well, letting them know that there is this issue and tell them to escalate to appropriate team, RMA or something.
otherwise you will be waiting alot until someone notices this ticket.
Here the same. The first device didn't want to charge, had a scratching noise with the hypersense and below 70% volume the speakers were different loud. Bought at the end of December 2021. Write to support for 1 month, then get a replacement device. There was no scratching on the goods, but the other two problems are still there. Now I'm currently writing to support again for a month (the same boring questions) to then get a third device. Razer does not want a reverse transaction. I've actually already given up, but if those are the rules of the game at razer, then I'll still play along. maybe the third device is as advertised. xD
Userlevel 3
Blase65
Here the same. The first device didn't want to charge, had a scratching noise with the hypersense and below 70% volume the speakers were different loud. Bought at the end of December 2021. Write to support for 1 month, then get a replacement device. There was no scratching on the goods, but the other two problems are still there. Now I'm currently writing to support again for a month (the same boring questions) to then get a third device. Razer does not want a reverse transaction. I've actually already given up, but if those are the rules of the game at razer, then I'll still play along. maybe the third device is as advertised. xD

This is strange, after first replacement i told them directly and pointed out this is previous ticket and if you cannot ensure it will work i want refund as it endagers my surroundings. And hell no im gonna risk fire at rented flat which i dont even own. And they accepted.
mhh. Maybe you showed more assertiveness than I did? Or it's because I'm not a native English speaker and the German support only works with google translator. Anyway, I will looking at device number 3 (support is pretty sure it's perfect this time) and if not I'll file a case with paypal. To let them decide if the contract is fullfilled or not. I mean other mothers have beautiful daughters too. :)
I just find it stupid that there is only one answer per day. It delays everything so infinitely. The support should really work faster. I haven't had a working headset for 2 months
Userlevel 3
Blase65
mhh. Maybe you showed more assertiveness than I did? Or it's because I'm not a native English speaker and the German support only works with google translator. Anyway, I will looking at device number 3 (support is pretty sure it's perfect this time) and if not I'll file a case with paypal. To let them decide if the contract is fullfilled or not. I mean other mothers have beautiful daughters too. :)
I just find it stupid that there is only one answer per day. It delays everything so infinitely. The support should really work faster. I haven't had a working headset for 2 months

yep even though you reply like 5 minutes after you still need to wait like day or two for response, this is unacceptable. I just played to their sense of logic, atleast as much as i can cause some of the customer support guys are close to zero in terms of inteligence. And used online support alot, meaning that my original ticket had like 4-5 smaller ones based on their online support, its always faster. And im not native english speaker as well... 😃 Hard time in eu razer support
I just got my headset yesterday on 3/9/2021. I have already had to call Razer support because the headset will not work when Synapse is running. As others have said, the charging never seems to ever reach full, and the light goes out on its own at random times, so I have unplugged and plugged it back in to resume charging based on the lights. The software toggles do not do anything at all, and Synapse will freeze with a prompt that says an error has occurred. Shortly after freezing, the battery icon in Synapse for the headset goes red and doesn't change.

When I close Synapse, the headset works flawlessly. I was able to be on discord for about 6 hours last night without issue. The haptic button works as it should as do the other features of the headset. As others have mentioned, I feel this is a software issue and not a hardware one.
Userlevel 3
KidDaGoat
I just got my headset yesterday on 3/9/2021. I have already had to call Razer support because the headset will not work when Synapse is running. As others have said, the charging never seems to ever reach full, and the light goes out on its own at random times, so I have unplugged and plugged it back in to resume charging based on the lights. The software toggles do not do anything at all, and Synapse will freeze with a prompt that says an error has occurred. Shortly after freezing, the battery icon in Synapse for the headset goes red and doesn't change.

When I close Synapse, the headset works flawlessly. I was able to be on discord for about 6 hours last night without issue. The haptic button works as it should as do the other features of the headset. As others have mentioned, I feel this is a software issue and not a hardware one.

as a workaround to audio output you can disable THX within synapse, that should help. This software should only unlock the feature anyway to this toggle will only mess things up. It's enough to activate it and set things up, then deactivate and you are good. Charging and other stuff are not fixed and will not be any time soon as i came to know from the ticket in my case where after loads of lies from customer support i came to know based on dev team they did not even touch it yet. So i am waiting again, wonder how long till i say fk it.