Kraken V3 PRO Charging issue | Razer Insider

Kraken V3 PRO Charging issue

  • 31 December 2021
  • 39 replies
  • 2201 views

Userlevel 1
I can't seem to get this headset charged up completely. I'm using the included cable on a 5V 2.4A USB port. Charged overnight and this morning the LED is still blinking.

On a related note, the Synapse app only shows a tiny battery representing the charged state. How about a percentage (%) indicator?

This topic has been closed for comments

39 Replies

I keep having the same problem. Even after updating the firmware. 😞
the firmware update worked for me
I am having the same problem I have charged it for 2 days/nights it won't connect and it shows the battery is dead on synapse
Userlevel 3
shadowrage
Hello! Thanks for your reply. Actually on my Krakens it starts charging with blinking white (probably Razer assumes it's yellow 😃 ) then later it switches to blinking green. Then it stops blinking an it shuts off. Let's wait for the Firmware upgrade anyhow :D

https://mysupport.razer.com/app/answers/detail/a_id/6091 there is finally new firmware
I bought these headphones last month and all of the above listed problems have happened to me. I am very disappointed with the terrible quality for such a lot of money. I think this is the last time I buy any product from razer
Dino89
Again, support lies 😃 ... it does not matter at which level you are charging.... its always blinking yellow. Actually i never changes to green, only it changes interval of blinking so it appears of being switched off but it is not. My last update from support was they have FW update which fixes charging issue to being ready by mid May.... apparently not happened ...


Hello! Thanks for your reply. Actually on my Krakens it starts charging with blinking white (probably Razer assumes it's yellow 😃 ) then later it switches to blinking green. Then it stops blinking an it shuts off. Let's wait for the Firmware upgrade anyhow 😃
Userlevel 3
shadowrage
Hello, sorry for rebouncing my own reply, just spoken with Razer chat support, I got this feedback

1) & 2) When charging from low charge, led is blinking yellow -> It should switch to blinking green when it's fully charged. After some minutes of blinking green -> led turns off (fully charged);
Additional info: you can use the headset via analog 3.5 mm cable while charging it via USB cable (keeping the headset wireless connection OFF)


Again, support lies 😃 ... it does not matter at which level you are charging.... its always blinking yellow. Actually i never changes to green, only it changes interval of blinking so it appears of being switched off but it is not. My last update from support was they have FW update which fixes charging issue to being ready by mid May.... apparently not happened ...
shadowrage
Hello all,
Experiencing similar issues here:

1) It's not clear when it's fully charged since there no % indicator. How should the led be? from blinking to green still? Or simply turning off?;
2) I noticed that after some minutes you re-plug it, then it stops blinking and it turns off? Is that 100% charge?
3) WIRELESS MODE ONLY: Some sound balancing problem on the headset between 80% and 40% volume wheel -> It doesn't happen when connected via 3.5 mm cable!

Are you also experiencing the same? Can you explain what's the normal charging led behavior on 1) & 2) ?
Thanks


Hello, sorry for rebouncing my own reply, just spoken with Razer chat support, I got this feedback

1) & 2) When charging from low charge, led is blinking yellow -> It should switch to blinking green when it's fully charged. After some minutes of blinking green -> led turns off (fully charged);
Additional info: you can use the headset via analog 3.5 mm cable while charging it via USB cable (keeping the headset wireless connection OFF)
Hello all,
Experiencing similar issues here:

1) It's not clear when it's fully charged since there no % indicator. How should the led be? from blinking to green still? Or simply turning off?;
2) I noticed that after some minutes you re-plug it, then it stops blinking and it turns off? Is that 100% charge?
3) WIRELESS MODE ONLY: Some sound balancing problem on the headset between 80% and 40% volume wheel -> It doesn't happen when connected via 3.5 mm cable!

Are you also experiencing the same? Can you explain what's the normal charging led behavior on 1) & 2) ?
Thanks
Userlevel 3
Blase65
How good is the hypersense of the nari ultimate? Similar as the kraken v3?

Its not bad, and next to krakens its a bit more hard and strong. Krakens and its hypersense is more smooth and soft which in my opinion is better. Also mic build is better as it is detachable which Nari lacks alot, and hypersense vibrations are interfering with it due to shaking mic in headset "hole". To overcome this i had to kinda modify it with sensitivity and i filled up the hole with some soft squishy material which is catching the vibes.
How good is the hypersense of the nari ultimate? Similar as the kraken v3?
Userlevel 3
Blase65
To keep you updated: I received the third device and surprise, all the problems are also present with this device. This time I didn't ask the support for help, but for a refund. Either they see that the entire series is defective and they cannot fulfill my purchase contract, or I open a case with Paypal. It's a real shame, because I like the sound of the device very much. PS. I think this continuous charging of the battery is dangerous - I'm now afraid that the device could catch fire. I pointed out to razer that they should think about a recall.
ok friends, that's it from me. I'll take a look at corsair and co.

Yeah it will not be fixed any time soon as i understood from my repetitive case about fix updates for this device. I like the sound as well, and same as you i think its a shame for Razer, i stick to my Nari Ultimate so far, until they fix this.
To keep you updated: I received the third device and surprise, all the problems are also present with this device. This time I didn't ask the support for help, but for a refund. Either they see that the entire series is defective and they cannot fulfill my purchase contract, or I open a case with Paypal. It's a real shame, because I like the sound of the device very much. PS. I think this continuous charging of the battery is dangerous - I'm now afraid that the device could catch fire. I pointed out to razer that they should think about a recall.
ok friends, that's it from me. I'll take a look at corsair and co.
Yeah I am just going to return this to Amazon. Not going to mess with it. Tried to "clean" install Synapse and drivers and still only the headset is having issues.
Userlevel 3
KidDaGoat
I just got my headset yesterday on 3/9/2021. I have already had to call Razer support because the headset will not work when Synapse is running. As others have said, the charging never seems to ever reach full, and the light goes out on its own at random times, so I have unplugged and plugged it back in to resume charging based on the lights. The software toggles do not do anything at all, and Synapse will freeze with a prompt that says an error has occurred. Shortly after freezing, the battery icon in Synapse for the headset goes red and doesn't change.

When I close Synapse, the headset works flawlessly. I was able to be on discord for about 6 hours last night without issue. The haptic button works as it should as do the other features of the headset. As others have mentioned, I feel this is a software issue and not a hardware one.

as a workaround to audio output you can disable THX within synapse, that should help. This software should only unlock the feature anyway to this toggle will only mess things up. It's enough to activate it and set things up, then deactivate and you are good. Charging and other stuff are not fixed and will not be any time soon as i came to know from the ticket in my case where after loads of lies from customer support i came to know based on dev team they did not even touch it yet. So i am waiting again, wonder how long till i say fk it.
I just got my headset yesterday on 3/9/2021. I have already had to call Razer support because the headset will not work when Synapse is running. As others have said, the charging never seems to ever reach full, and the light goes out on its own at random times, so I have unplugged and plugged it back in to resume charging based on the lights. The software toggles do not do anything at all, and Synapse will freeze with a prompt that says an error has occurred. Shortly after freezing, the battery icon in Synapse for the headset goes red and doesn't change.

When I close Synapse, the headset works flawlessly. I was able to be on discord for about 6 hours last night without issue. The haptic button works as it should as do the other features of the headset. As others have mentioned, I feel this is a software issue and not a hardware one.
Userlevel 3
Blase65
mhh. Maybe you showed more assertiveness than I did? Or it's because I'm not a native English speaker and the German support only works with google translator. Anyway, I will looking at device number 3 (support is pretty sure it's perfect this time) and if not I'll file a case with paypal. To let them decide if the contract is fullfilled or not. I mean other mothers have beautiful daughters too. :)
I just find it stupid that there is only one answer per day. It delays everything so infinitely. The support should really work faster. I haven't had a working headset for 2 months

yep even though you reply like 5 minutes after you still need to wait like day or two for response, this is unacceptable. I just played to their sense of logic, atleast as much as i can cause some of the customer support guys are close to zero in terms of inteligence. And used online support alot, meaning that my original ticket had like 4-5 smaller ones based on their online support, its always faster. And im not native english speaker as well... 😃 Hard time in eu razer support
mhh. Maybe you showed more assertiveness than I did? Or it's because I'm not a native English speaker and the German support only works with google translator. Anyway, I will looking at device number 3 (support is pretty sure it's perfect this time) and if not I'll file a case with paypal. To let them decide if the contract is fullfilled or not. I mean other mothers have beautiful daughters too. :)
I just find it stupid that there is only one answer per day. It delays everything so infinitely. The support should really work faster. I haven't had a working headset for 2 months
Userlevel 3
Blase65
Here the same. The first device didn't want to charge, had a scratching noise with the hypersense and below 70% volume the speakers were different loud. Bought at the end of December 2021. Write to support for 1 month, then get a replacement device. There was no scratching on the goods, but the other two problems are still there. Now I'm currently writing to support again for a month (the same boring questions) to then get a third device. Razer does not want a reverse transaction. I've actually already given up, but if those are the rules of the game at razer, then I'll still play along. maybe the third device is as advertised. xD

This is strange, after first replacement i told them directly and pointed out this is previous ticket and if you cannot ensure it will work i want refund as it endagers my surroundings. And hell no im gonna risk fire at rented flat which i dont even own. And they accepted.
Here the same. The first device didn't want to charge, had a scratching noise with the hypersense and below 70% volume the speakers were different loud. Bought at the end of December 2021. Write to support for 1 month, then get a replacement device. There was no scratching on the goods, but the other two problems are still there. Now I'm currently writing to support again for a month (the same boring questions) to then get a third device. Razer does not want a reverse transaction. I've actually already given up, but if those are the rules of the game at razer, then I'll still play along. maybe the third device is as advertised. xD
Userlevel 3
veronikaveber
I have also a problem with charging my headset. For the first month, it was great and everything was okay regarding charging the headset and now I can't charge them anymore. They all the time empty and I can't use them. Do you think that this is some software problem or it is the headset? They are almost 200 and now I can use them. I don't know what to do.


Hi Veronika, that is really unfortunate and makes me think i did right choice in my case when i returned it, as it clearly shows that charging is major issue here (some folks did not notice so far that headset is overcharging and killing battery itself) that needs to be fixed asap.
Looks like HW or FW issue that is for sure, and your only option is to create ticket and let Razer handle it. I would also suggest to either create ticket via Customer online support, where you need to explain the issue and tell them to escalate it asap. Or if you create ticket by yourself, immediately contact online support as well, letting them know that there is this issue and tell them to escalate to appropriate team, RMA or something.
otherwise you will be waiting alot until someone notices this ticket.
I have also a problem with charging my headset. For the first month, it was great and everything was okay regarding charging the headset and now I can't charge them anymore. They all the time empty and I can't use them. Do you think that this is some software problem or it is the headset? They are almost 200 and now I can use them. I don't know what to do.
Userlevel 3
Casper1390
I've been struggling to get mine picked up to be honest! They missed my first collection day because support were too busy to make the arrangements, now their sending me the transport label via email the same day as the package is being collected.... Hopefully DHL don't get here first!

In my case i waited for label then calmly prepared the package and then went to DHL "box" which is near and can be used to collect or get packages. And i put it there myself :D

Anyway yesterday i received new RMA number with return and refund luckily, therefore they send label to somewhere in Netherlands. Today i received new email with apology that it was directed to wrong warehouse and they sent new label to send it somewhere in Singapore surprisingly. So hopefully its okay now, luckily the time they were sending it was almost night for me 😃
I've been struggling to get mine picked up to be honest! They missed my first collection day because support were too busy to make the arrangements, now their sending me the transport label via email the same day as the package is being collected.... Hopefully DHL don't get here first!
Userlevel 3
FiszPL
It may be also batch problem, that is unsolveable by FW.

It looks like this new device is somehow new batch atleast serial number is way different. But thats just asumption.
You could be right, but it depends on them whether they allow me new RMA or refuses.