why cant i sign in to razer central???? | Razer Insider

why cant i sign in to razer central????

  • 12 October 2020
  • 9 replies

when I try to sign in it says something like this:

unable to get a new web socket connection from the pool in stage 1: remote error: tis: handshake failure

and I know my password and everything, I even reset it and it still shows this. Can anyone help me?

This topic has been closed for comments

9 Replies

I am experiencing the same issue, any help?
also, I tried to sign in with facebook and google, and it did not work either. I don't have a twitch account.
Same issue here. Any luck my ppl?
me too, has anyone got it to work?
same, is it working for anyone yet?
Did a fresh Win10 install on Blade Stealth 13 (Late 2019) and now having the same issue. Never had this or any issues prior.
Same issue... Its a shame i spend $200 on a mouse and keyboard and they cant even keep severs up so i can sign in and do my first time setup
just signed in, literally did nothing different and it worked
Same issue...