2020 Razer Blade Advanced USB-C PD Charging Issues

Discussion in 'Systems' started by wirelessnet2, May 23, 2021.

  1. Base0x02

    Base0x02 New Member

    Sorry if you've checked this but there is a Allow USB Charging option in the bios that was disabled by default on my laptop. I've got it enabled and its charing with my apple USB-C charger.
     
  2. wirelessnet2

    wirelessnet2 New Member

    IIRC that option is for the USB-A ports. Anyways, I have that enabled.
     
  3. wirelessnet2

    wirelessnet2 New Member

    I bought Razer's own Thunderbolt 4 Dock Chroma for testing. Guess what? It doesn't charge my Blade 15 at 90w. It's also stuck at 60w. Razer screwed up their implementation of USB-PD so badly that their own dock doesn't work properly with their own laptop. wtf
     
  4. This thread still alive?
    I just got my Razer USB-C 100W GaN charger and I too see the 60W limit charging my RB14. Odd behaviour us that I get more like 80W if I boot with it connected, but revert to 60W if I unplug and plug it back in.
     
  5. wirelessnet2

    wirelessnet2 New Member

    Yeah thread is still technically alive. Razer support said they identified the issue and are working on a fix. If it will ever come... idk.
     
  6. flaming_lemons

    flaming_lemons New Member

    keep us posted, please.
    I really don't need the TB4/chroma dock (yet!) so I would be interested in what works in terms of Thunderbolt and PD

    What I need is a docking station that
    - powers the 15" blade (2020, base model, GTX1660) laptop
    - can provide pixels to at least one 4K@60Hz screen
    - does proper networking and can connect 3 or 4 USB devices.(charge&sync my phone, headphones etc..)

    my plan is to start with the "amazon basics" 11-in-1 thunderbolt 3 dock - it claims to deliver 60W to the laptop - cost is ~EUR 100,- so that would be a steal if it works.

    If not, then I will work my way up to Anker "powerexpand elite" thunderbolt dock (it claims to do 85W PD via TB3) - pricetag is ~EUR 300,-
    Alternatievely there is the Anker Apex TB4 dock, it claims to deliver 90W PD to the laptop. Same price tag.

    There is an i-Tec TB dock that claims 3x4K screens and 96W PD - but I don't know the brand, that would be ~EUR 250,-

    If all else fails there is the Razer chroma dock.. but if it is really stuck at 60W as @wirelessnet2 reports, then it's not worth the ~EUR330,- price tag IMO

    sadly there seems to be nothing in between 100 and 300 euros.. except aliexpress stuff which is notoriously bad at receiving aftercare / driver / firmware updates.
     
  7. wirelessnet2

    wirelessnet2 New Member

    As of right now, no Thunderbolt certified docks will charge the laptop at any rate over 60W. If someone somehow manages to sneak a true 100W power delivery dock past Intel certification, I'd assume it would work. I have contacted Razer support, and they said they have identified the issue, and they are apparently working on a fix, though I have no clue how long that would take.

    If you want to try some docks, I'd maybe try to find a USB-C/Displayport Alt Mode (NOT THUNDERBOLT) dock that advertises true 100W USB-PD. I haven't tried one of those yet, but I think it should actually deliver the full 100W.
     
  8. D1m3b4g

    D1m3b4g New Member

    I'm really glad I found this thread. I've been trying to work out for ages why my 90W Dell TB dock and my 90W Dell USB-C charger wasn't getting close to running the system at idle, let alone doing anything intensive.

    I was dismayed by the fact there was nothing built into the internal software, power profile-wise that realises the system is on USB-C power and adjusts performance in-line with the power delivery. It's either battery or mains, which is completely pointless if the "mains" the system is scaling for is 230W and it's actualy getting 60W.

    I can see the battery just start draining by the percentage in real time when this occurs until the laptop just runs out of power and turns off.

    Dell do have a 130W USB-C charger out at this point which I'm sure supports 20V @ 5A (£68 - Amazon) so I think I'll invest in that and see if it makes any difference. Perhaps the system will have a better change of lasting a tad longer @ 100W then 60W - but in general, I agree that Razer seem to have made the biggest possible screw up in regard to implementing USB PD, from both a hardware and a bios/software perspective.

    The only thing it is useful for is charging the laptop when completely turned off which pretty much defeats the entire point of it, made even more hilarious when the same thing appears to happen when docked to their own products.
     
    Last edited: Oct 18, 2021
  9. Pavlogal

    Pavlogal New Member

    Just checking is this still being worked on? I also have a Blade Advanced 2020 and USB-C charging was always funky. I got a 100W GaN charger and an e-marked cable but charging only works *sometimes*. When booted up plugging into the left (non-TB) port will sometimes randomly work, literally no idea why it's not consistent. Plugging in first and then booting up works almost always. The right (TB3) port never worked (for charging).

    For me it either works or it doesn't and I never established the charging speed because I don't have a way to measure it.

    I also saw your reply on notebookreview forums asking for pics of USB-PD ICs to try to get around Razer's propriotary bs. First I gotta say that's unfathomably based and awesome and thanks for bringing that up.

    Either way, I'm just asking if there's any news and I'm considering getting a USB-PD protocol analyzer and CH341a programmer and do some testing myself. It will take a while for those things to ship though.
     
  10. wirelessnet2

    wirelessnet2 New Member

    @Pavlogal Razer admitted that the laptop has issues with charging. They told me they were able to reproduce the issue in their lab. That was like a year ago. They probably will never release a fix. Which is why I will never buy another Razer laptop. Piss poor support.

    The 2020 Blade 15 Advanced uses the Texas Instruments TPS65987DDJ USB-C controller for both USB-C ports. They have separate firmwares. I dumped the firmware for the TPS65987DDJ connected to the Thunderbolt-enabled port and tried to reverse-engineer the region of the firmware that normally holds the USB-PD Sink Capabilities, but it looks empty, or I'm just bad at reverse engineering stuff. I have a suspicion that the ITE Embedded Controller (EC) is controlling these TPS65987 chips over I2C or something, and that the TPS chips are not actually programmed to handle charging independently.

    I've abandoned the reverse engineering effort for now, as college is kinda killing me.
     
    Pavlogal likes this.
  11. wirelessnet2

    wirelessnet2 New Member

    The TPS65987 firmware probably has some hash or checksum or something that prevents me from just editing parts of it. There's a few options to move from here:

    1. Try to talk to the TPS chips over I2C. If we can do that then maybe we can force them to do things we want.
    2. Try to access the hardware I2C debug interface of the TPS chips. I assume this would require soldering wires onto the motherboard. Not great.
    3. Dump the firmware (already done), correctly edit it (stuck here), and then flash this firmware back to the SPI memory connected to each of the TPS chips (easy).

    If anyone wants to try help pls dm me thanks
     
    Pavlogal likes this.
  12. Pavlogal

    Pavlogal New Member

    That is almost certainly the case: https://e2e.ti.com/support/interfac...ace-forum/806741/tps65987ddj-firmware-support

    If EC firmware could be reverse engineered that would br great but obviously it wouldn't be an easy feat. Ideally Razer would make their EC firmware open source kinda like System76 but that's never happening. The least I expect from Razer is to fix this issue themselves. If the firmware source code is locked in their hands already they have a duty to maintain it. If we can't fix it ourselves then they have to. I understand that their current focus is on newer laptops but is fixing a PD issue in firmware really that difficult?

    Honestly Razer disappointed me. I have a Blade that's usually such an awesome laptop but it has these tiny issues that will never be fixed and support that doesn't care. I really hope Framework realeases a 15-16" laptop with a replaceable GPU. If that happens I am SOLD.
     
  13. wirelessnet2

    wirelessnet2 New Member

    @Pavlogal The EC in the 2020 Blade 15 Advanced is the IT8390VG-256. I can't find anything about this chip online. Though we have had an EC firmware update for this... maybe I can try to look at the binary downloaded from Razer's website, but I have no idea how the ITE firmwares work so not sure that would be terribly useful.
     
    Pavlogal likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >