Battery not detected on Razer Blade Stealth 2016

Discussion in 'Systems' started by Theoooh, May 19, 2019.

Thread Status:
Not open for further replies.
  1. Theoooh

    Theoooh New Member

    Ok so lemme give you the low down, I'd put this thread in the Razer support section but I don't need support from Razer yet, so here's what's been going on...

    I've been using my Razer blade stealth v4 2016 (Intel 7500u) as a daily driver and suffice to say it's worked well for roughly a year and a half before problems started appearing, mainly issues with the laptop's CPU. I've sent my laptop in for an RMA twice in 2018 and want to send it in for an RMA only as a last resort.

    So the issue is that the battery isn't being detected and I've done the common sense stuff such as:
    • Uninstalling then reinstalling the battery drivers in device manager
    • "Restoring" my laptop to a previous working state
    • doing a complete hard reset
    • opening my laptop up and having a look at the internals
    If anyone has any ideas as to fixing this issue please comment and help me, like I said I want to fix it myself and not send my laptop in for an RMA because I really need it for schools since I have major assignments due and can't risk not having a laptop (unless Razer wants to send me a free one lmao :wink_:)

    Thanks for all the help in advance.
     
    0V3R_K1LL and DRIFT_IT like this.
  2. Joikansai

    Joikansai Well-Known Member VANGUARD

    Is the battery detected on hardware manager? If yes try check the capacity and discharge rate like using HWinfo64, if not open it and try unplug the battery for a while and plug it again, still not try reset cmos (idk where it’s located on stealth something like this on Blade 14, google it how firstly before you do this). If still doesn’t work send it for repair lol, or get battery from eBay (personally I don’t recommend but some dude doing this).
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >