Blackshark V2 THX Spatial Audio Not Working Properly

Discussion in 'Razer Support' started by vexx32, Apr 26, 2021.

Thread Status:
Not open for further replies.
  1. vexx32

    vexx32 New Member

    I recently purchased a Razer Blackshark V2 headset. I set up the Razer Synapse application and turned on the THX spatial audio, but unfortunately, instead of making the audio quality better, it makes it much worse.

    I mostly play FPS games like Apex, R6S, Valorant, and CS:GO, so I use the manual THX setting and choose the THX Competitive option. I also set custom EQ settings for each game. Although I hear the in-game sounds just fine with THX off, with THX on it's muffled like I'm hearing them through a tin can telephone or an old radio. As soon as I alt-tab or turn the THX off sound turns back to normal. Razer Synapse automatically sets the headset as the default device when I plug the headset in, so I doubt that is the problem. I have never used a Razer product before, so is there something that I don't know about? Can somebody please help me so I can use the headset to its full extent?
    AnipR15 and Clutch313 like this.
  2. sihorx

    sihorx New Member

    Hi. Did You find solution?
    I have the same expierience.
    Becouse that I stopped use THX- but I want use it.
    I Tried use many diffrent settings but nothihg change.
    Sound when THX is on- always sounds - as You sad - I'm hearing them through a tin can telephone
    Please let me kown or anybody who have any idea how to fix it
    Clutch313 likes this.
  3. FredrikH

    FredrikH New Member

    I got the same problem with my Blackshark V2.
    If someone finds a solution please let me know too. :)
    Clutch313 likes this.
  4. Clutch313

    Clutch313 New Member

    I am having this same issue with COD: Warzone. At first I thought it may be an issue with Warzone’s audio, but seeing this post verifies that my initial gut feeling was correct in that it is a synapse software issue, and likely specifically with the Blackshark V2 Pro. I previously used the Kraken Ultimate headset and it’s THX audio in Synapse 3 with no such issues, and I have also previously used Razer’s THX Spatial Audio app successfully with no such issues.

    When I recently updated to the Blackshark V2 Pro on 5/31/2021, all hell broke loose. I have completed every troubleshooting step I can find on these forums - including firmware updates and Synapse 3 reinstall - with no success in resolving the issue. I have not reset my Windows OS because that is not something I am willing to do. I will return the headset for a refund before I ever reset Windows. I am extremely disappointed at the prospect of having to return this headset, so I hope this issue can be fixed soon. I think the hardware in this headset is top-class, but unfortunately it seems that the software team at Razer doesn’t have the same high-quality standards that I have become accustomed to from the hardware team. When I pay $200 USD for a headset and it doesn’t work as advertised, regardless of whether it is software or hardware related, that is completely unacceptable. Razer needs to give its software team a kick in the pants, and this issue needs to be fixed VERY soon.
    Last edited: Jun 7, 2021
    enzotriolo likes this.
  5. Clutch313

    Clutch313 New Member

    Bump. This is still happening. Anyone find a workaround or fix for this?
  6. USMC-Exterior

    USMC-Exterior New Member

    Bump. This is still happening. Anyone find a workaround or fix for this?
    Clutch313 likes this.
  7. Clutch313

    Clutch313 New Member

    In the Synapse update a few days ago, the “what’s new” notes said bug fixes and performance improvements the Blackshark V2 Pro. I got so excited thinking this issue would be fixed…

    It wasn’t.
  8. AnipR15

    AnipR15 Active Member

    I cant help on this situations. I did faced this issue before, but after the trial expired, I'm not using the THX anymore. Maybe we can get help from @Razer.Caziel @Razer.Speedcr0ss .

    **Subscribed to the thread, also like to get the answer of this issue.
  9. Clutch313

    Clutch313 New Member

    @AnipR15...just clarifying because I don't want to confuse anyone that sees this in the future....we are not talking about the THX app, we are talking about THX through Synapse 3 while using the Blackshark V2 Pro. The BS V2 Pro cannot be used with the THX app. That would make way too much sense for Razer to let us do. Unfortunately, Razer forces you to use Synapse's THX when using the BS V2 Pro.
  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey guys! Have you tried uninstalling the 7.1 Surround Sound App and reinstalling it? Please try the workaround from this thread and restore/refresh your THX Spatial Audio driver. Feel free to send me a PM should you need additional assistance.

    Thanks for the mentioned @AnipR15!
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >