BLADE 15 screen goes on and off after sleep mode

Discussion in 'Systems' started by Vartesh18, Aug 27, 2021.

Thread Status:
Not open for further replies.
  1. Vartesh18

    Vartesh18 New Member

    Hi,

    I've been recently having issues with my Razer Blade 15 2019 Advanced.

    The problem I'm having is that every time I put the pc on sleep mode and get it on again after a while, it enters a "phase" where the screen goes on and off randomly. It shuts off for less than a second and goes back on for minutes before shutting down again.

    The only solution I found is rebooting the PC and the problem disapears (until I put it to sleep again..)

    I've checked a lot online and have not yet found someone with this precise problem.
    I obviously updated all the drivers several times and it still did not fix it.

    Thank you in advance for your answers !
     
    ChaoticWyrme and pancholr like this.
  2. ChaoticWyrme

    ChaoticWyrme New Member

    I have the same problem, it just started the other day.
     
    Vartesh18 and pancholr like this.
  3. ChaoticWyrme

    ChaoticWyrme New Member

    I found this reddit thread:
    https://www.reddit.com/r/razer/comments/ismjcq/razer_blade_15_advanced_2019_screen_flicker/

    It suggests that it may be the display getting set to 240hz. Try setting the display framerate to 60hz.
     
  4. Vartesh18

    Vartesh18 New Member

  5. Vartesh18

    Vartesh18 New Member

    I've tried this method and it works, sometimes.
     
  6. Vartesh18

    Vartesh18 New Member

    I sometimes get long black screens now, when it happens. Have to force reboot the pc to get out of it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >