Choppy and distorted audio, no monitoring

Discussion in 'Razer Support' started by PlaguePS, Sep 22, 2022 at 10:38 AM.

  1. PlaguePS

    PlaguePS New Member

    I'll try to keep myself short. I'm trying to record / broadcast gameplay from my PS4 with the Razer Ripsaw. I followed the manual and connected the PS4 to the HDMI input on the capture card (CC), and connected the monitor / TV to the HDMI output on the CC.
    Now, if I plug my headphones into my PS4 controller, I can hear the game audio, but none of it is being recorded - alright. So I pull out my headphones, and make another brief recording. This time, the game audio is there, but it is EXTREMELY choppy and distorted, and of unacceptable quality.

    I looked online, and what I found is that installing THX Spatial Audio (the trial version; I'm not willing to pay $20 to fix something that should be working to begin with) and using it as the audio driver has helped, and that the in-game audio was not distorted in the video recording anymore.

    HOWEVER - I cannot hear / monitor the in-game audio at all! I tried plugging my headphones into my laptop, I tried plugging it into the AUX *and* the MIC input on the CC respectively, but nothing works! So now, when using Spatial Audio, I end up recording decent audio but I can't hear anything during the actual recording!

    My question is - where does this choppiness and distortion in the audio come from? And how exactly do I hear the in-game audio WHILE recording, while also having it recorded in the video?
    I feel like I'm slowly losing my mind, there is nothing 'Plug & Play' or 'Easy' about this, and I'm seriously desperate for a solution at this point. (Note: I'm using OBS)

    Edit: The video recording itself is perfectly fine, I'm explicitly only having problems with the audio.
     
  2. Razer.Zionzedd

    Razer.Zionzedd Yes, My lord? Staff Member

    Try to update both Windows OS and the Synapse application. Check in the Windows Sound settings if the box "Allow applications to take exclusive control of this device" is checked. You can also try to repair the Synapse app by following the steps here. If that didn't help, PM me the serial number so I can validate its model and check for other steps to help you resolve the audio issue of your Razer Ripsaw capture card.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >