Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

FPS issues after Razer Cynosa Chroma Membrane

Discussion in 'Keyboards' started by frontHotMagentapark121, Dec 9, 2019.

Thread Status:
Not open for further replies.
  1. Hello, I bought recentlyRazer Cynosa Chroma Membrane keyboard. everything is fine it's working great and rgbs is really good. But i noticed something I had stable frame rates and constant 60fps from my recent games. Warhammer vermintade 2, RDR2, Star Wars battlefront 2. I don't even play highest settings at all. High is fine to me. Anyway, after installing ryzen synapse 3 beta or iCUE (from corsair aio cooler) software, i didn't figure it out for now, I installed these same day, My gaming fps is dropping dramatic scenes. It is not stable 60fps and dropping below to 60. What should i do for this ? I'm monitoring with MSI afterburner. temps are fine, clock speeds still same.

    My specs:
    ryzen 2700x
    rtx 2070
    16gb DDR4 3200mhz ram

    What i have tried so far:

    Uninstalled Razer synapse, icue
    unplugged razer keyboard and tried older keyboard
    reinstalled nvidia driver

    nothing changed still having issues with FPS drop.
     
  2. daftpunk639

    daftpunk639 New Member

    Firstly play in highest fps and try lower some other settings if possible
    second if it is not your computer go on Razer synapse 3 and get rid of gaming mode and unfortunately your settings for it but you can keep the lights
    also go to settings devices Razer cynosa chroma and press reinstall drivers this may fix it even if the problem is not your computer I'm sorry if this does not help but I tried
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >