Kraken V3 Pro - Another pair and the same problem.

Discussion in 'Audio' started by mini2109, Oct 8, 2022.

  1. mini2109

    mini2109 Member

    Good day.
    Some time ago I wrote about my problems with the Razer Kraken V3 Pro headphones.
    It was about disconnecting the sound.
    I reported the matter to the seller (Media Ex) and after exactly 2 weeks (because that was the store to answer) I was informed about replacing the headphones with new ones.

    Unfortunately, the headphones returned to me with the same problem I sent them back with.
    When some material is being played (eg movie on yt) the headphones work normally.
    When the song / movie ends and the next one starts loading, or the page is simply closed and a new one opens - the headphones go silent, you cannot hear anything, you have to turn them on and off.
    The same problem is described here:

    When you listen to one song, podcast, or while playing - this problem does not occur.

    The second problem - when listening for a long time, the sound from time to time starts to interrupt for a few seconds (the sound fades, returns, fades away, comes back 3-4 times and then normalizes).

    I have already checked it on various applications and games.
    The headphones are about a meter from the transmitter on the pc.
    Already tried on different usb ports.

    Once again, I reported the matter to the seller and I'm waiting.

    I wonder if this type is so and this model is damaged or how ...
     
    JR_1018, FiszPL and pancholr like this.
  2. AfteMath

    AfteMath New Member

    I have the same problem, exactly the same. Did you manage to resolve this? Thanks
     
  3. mini2109

    mini2109 Member

    I gave them back again under the guarantee and I am counting on my money back :) Now I am looking for new ones.
     
  4. AfteMath

    AfteMath New Member

    I found a trick.

    Just turn THX off inside the Synapse App for Windows. Problem solved. I don't need THX.

    Cheers
     
  5. mini2109

    mini2109 Member

    I tried to turn everything off - it was one of the advice from the support.
    I even uninstalled applications responsible for surround sound and even Synapse itself.
    I tried on another computer that never had these applications - it doesn't help.
     
  6. mini2109

    mini2109 Member

    Update.
    Due to the black firday and the promotion - I bought the Kraken V3 Pro (3 or 4 pair) again.
    At the same time I also bought a SteelSeries Actis Nova 7x (to connect to Xbox in case)
    guess...
    it myself.
    The Krakens lost sound again even though they worked normally, the backlight worked, but there is no sound in the headphones.
    I used headphones from SS as well and no problem.
    Everything works - nothing cuts ... unfortunately, the Nova 7x has a terrible microphone in my opinion and there is nothing to compare it to the Kraken.
    The question is what is it, because it's a bit strange.
     
  7. mini2109

    mini2109 Member

    A small update.
    I checked on another computer and there was no problem.
    On my sister's pc There was no problem and she used them for a few hours, where I had jamming in the first 10 minutes.
     
  8. AfteMath

    AfteMath New Member

    I will try it again with the THX function on. Maybe they sorted it out with the updates they had.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >