MAC OS Synapse do not detect mouse after restart system

Discussion in 'Razer Synapse' started by RedpaX, Nov 15, 2019.

?

Do you have the same problem?

  1. Yes!

    97.7%
  2. No.

    0.4%
  3. I do not know...

    1.9%
  1. Darthjack2020

    Darthjack2020 New Member

    I'm back to Logitech! Sorry, but I changed my logitech mouse for a Razer, I have dual boot on mac, under windows everything works fine, but on Mac os, that's another story ... I will return the Razer and buy another Logitech ... it seems misleading and false to say that it is compatible with Mac, if it works, but any other $ 10 mouse !!!!
     
  2. BryghtonTalksTech

    BryghtonTalksTech New Member

    Me too
     
  3. coolOPALAmazon725

    coolOPALAmazon725 New Member

    yw https://github.com/1kc/razer-macos
     
  4. heyjb99

    heyjb99 New Member

    Same issue here on MacOS big sur + apple silicon M1 on macbook air.
     
  5. 3212009

    3212009 New Member

    same thing here
     
  6. arturlp3

    arturlp3 New Member

    I am with the same problem on macOS Big Sur. I have installed Synapse 2 and the program initially recognizes my mouse Deathadder Chroma. Unfortunately, minutes latter Synapse 2 does not recognize anymore. Do I need to downgrade my operational system to the macOS Mojave (10.14)?
     
  7. Guenther22

    Guenther22 New Member

    I came across this forum on my search for a solution for the named problem and found it somewhere else xD

    I tried to use my PS3 controller as a PS4 controller and for that I needed to turn off System Integrity.
    After that I realised, that Razer Synapse detected my deathadder expert again. And as soon as I turned that feature on Razer couldn't find the mouse any more.

    Here is the instructions on how to turn that off
    https://www.imore.com/how-turn-system-integrity-protection-macos

    Hope it helps, but I am most certainly going buy an other mouse ...
     
  8. i got same problem as you bro
     
  9. i have the razor viper mini and when i use the synapse 2 app it says please connect a razor synasnpe enabled device
     
  10. JoJoTheJet

    JoJoTheJet New Member

    Here on Big Sur and the m1, haven't messed around much, but its not showing up. My mouse sensitivity keeps changing and was hoping Synapsis would help :/
     
  11. mobborazer

    mobborazer New Member

    same thing here
    and wtf razer???

    DO NOT BUY RAZER FOR MAC!
     
  12. JustAnOtaku

    JustAnOtaku New Member

    this happens to me too, except when i unplug and plug it again, it still doesnt work.
    Ive read through this forum, do we just need to be patient until razer has made S2 Compatible?
     
  13. Jackliao

    Jackliao New Member

    having the same issue. the razer synapse is not working with macos
    i tried to assign the mouse by windows, save it and plug the mouse back to mac
    it work as the way i assign the buttom
    i guess that's the only way to make it work
     
  14. Mac Catalina and I can't run the software as the Razer Synapse is stuck at "Approval Required" with only one check mark at the first option Allow Access... and the Allow System software, does not respond and there is not dialog to "allow" in the system preferences. I have rebooted twice.

    What do I do now?
     

    Attached Files:

  15. PidgeyQueen

    PidgeyQueen New Member

    I also have the message "please connect a razer enabled device" on my macbook. Will this ever be addressed?
     
  16. KBR777

    KBR777 New Member

    Doesn't work for me and Im running Mojave, how on earth is it not working on an older version of OS X??
     
  17. wackiislandboi

    wackiislandboi New Member

    yeah this is an issue, I guess I am returning this $80 mouse
     
  18. sebastiancristancho

    sebastiancristancho New Member

    Helloooo it’s been 13 months since your dedicated team was supposed to realize an update?
     
  19. meganmarye

    meganmarye New Member

    I am a Mac and PC owner. All I want to do is be able to use my Razer BlackWidow V3 on them both. Razer, if you can't handle making your software work on Mac AND PC - just say so. Lying to us saying that it is compatible on both is just PURE laziness. Please attempt to do the bare minimum and actually have the guts to respond to any of these people 1 year+ later.
     
    Sprockettfuel likes this.
  20. Sprockettfuel

    Sprockettfuel New Member

    I have the same Keyboard and have spent the last hour trying to register it for the warranty which doesn't work (i bought directly from Razer) and to customize my keys. What a waste of money, right? Why couldn't it just say that it doesn't work on mac? Super disappointed. I love the haptics on this but the colors cycling through as default is annoying. Why would it say cross compatible if its not? I even tried the GitHub workaround but that has no support for BlackWidow V3 so back to square 1. These peripherals are far too expensive to not work
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >