Mic has noise surpression despite all settings toggled off.

Discussion in 'Razer Support' started by everNATURALZIRCON131, Sep 12, 2021.

Thread Status:
Not open for further replies.
  1. I have a razer Kraken headset/usb audio controller, and using Razer Synapse 3, I have updated Synapse 3, reinstalled it, restarted my PC and I am still having these issues. I do not have any other audio software installed.

    I always have people in-game complain that they can't hear my mic when I know it has always worked perfectly fine. I decided to listen to myself once again to make sure everything was working correctly, and I noticed there was a very bad noise-suppression being applied to my mic. I do not remember this happening in the past but it has been a couple of months or more since I've last checked how my own mic sounds.
    I tested other microphones and they did not have this issue, only my razer headset.
    I've gone thoroughly through all my settings, all my Synapse mic settings are turned off to have no noise suppression, and I've gone through all windows sound control panel and sound settings and made sure there wasn't any noise suppression enabled.
    My voice gets cut out constantly when I'm speaking making it very hard to understand. I do not have much background noise. It is only suppressing my speech for no reason. I am sure it's something Razer related since it is only my Razer headset that's doing this, while other microphones that aren't friendly to use for me, sound perfectly fine.

    Please tell me what's adding this noise suppression. I do not like it. There is no setting that I haven't turned off that fixed it. I can't always talk very fast, so my voice gets sharply turned down and then muted entirely because of it while I am in middle of talking.
     
    Last edited: Sep 12, 2021
  2. Razer.Xenon

    Razer.Xenon Active Member Staff Member

    Have you tried disabling Synapse to check if it behaves the same without it running in the background? For now, let's isolate the issue by following the steps on this page. But if the problem remains apparent, PM me the serial number of your device. I can use that to verify its model and help me look for a way to fix this.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >