naga trinity issue (switch off/on)

Discussion in 'Razer Support' started by MichaelCorleone, Apr 7, 2019.

  1. MichaelCorleone

    MichaelCorleone New Member

    Hi everyone

    I've bought a naga trinity 3 weeks ago, and since then , im gettin this issue:

    While i'm playing a game, or even i'm just on the internet, my mouse switch off, and on (no more lights on the mouse, and the side panel buttons aren t usable anymore, then it switch on , and goes off , and on etc etc)

    I've tried many things to fix this, but since i' don t really know where the issue comes from, i couldn t manage to fix it.

    If you guys can enlighten me about this, it's really annoying.

    Thank you fellas.
     
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    This issue you have from the biging or just recent show up, when you close synapse mouse also turn off, on difrent pc is the same issue ?
     
  3. MichaelCorleone

    MichaelCorleone New Member

    Hi
    I did get the issue since the begining, even when i close synapse and use the internal profil that i made , it still switch off . I haven t tried it on another computer yet
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    If you can try mouse on d iffrent pc mayby someone from family or friend. From there we can try to fix this will give more info where to look it. From description it looks like power issie but for now is hard to say.
     
  5. MichaelCorleone

    MichaelCorleone New Member

    thank you, i ll try it on another computer and then i ll tell you.
     
  6. BlackFireDragon

    BlackFireDragon Well-Known Member

    Ok i wait for respond from you and we see what go next :)
     
  7. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @MichaelCorleone

    Are you getting a disconnect/reconnect sound cue when this happens? Please send me a PM. It'd be my pleasure to help you troubleshoot and hopefully sort this out.
     
  8. Im having the same problem, no sounds for connecting or disconnecting occur but spamming the buttons seems to bring it back faster than waiting. The main left/right click and middle mouse works its just all the LED's and the side panel buttons stop functioning. If you uninstall all the drivers including the windows 10 provided ones the mouse will work for the day. Its seems a windows update has broken the side panel functionality. Just my 2 cents from what I've experienced so far.
     
  9. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Could be an angle worth looking into. Please send me a PM with your Synapse 3, Application and System logs.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >