Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

New Razer Phone 2 touch issue

Discussion in 'Razer Support' started by Syseal, Apr 8, 2019.

Thread Status:
Not open for further replies.
  1. Syseal

    Syseal New Member

    Hello everyone.

    I bought a new RP2 via amazon and it arrived today.
    Everything worked fine, i have setup the phone, renewed the backup from my old OP6T and enjoyed the new experience.
    However once I locked the phone and let it be locked for more than 2 seconds, the phone would unlock with fingerprint but touch would not be responding. I could see the display working as I could adjust the volume and and see the slider moving. I could have video playing and that would still play. The phone just doesn't respond to touch input.

    I have tried :

    - reboot
    - factory reset
    - setting it up without any accounts or backups from previous phone (thought maybe old settings caused some problems)
    - changing the default launcher

    Nothing helps. Once i start the phone touch works until I lock the screen and unlock it again. Then it stops working.



    If anyone has any idea how to resolve this issue that would be great as I love the phone and would like to prevent sending it for RMA.



    Thanks in advance
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Have you tried doing a hard reset? You can do it by pressing down both of the power and volume up buttons at the same time until it reboots. Let me know if the issue persists after the reset.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >