Razer basilisk v2 on synapse 2?

Discussion in 'Razer Synapse' started by Hazardoze, Apr 19, 2020.

Thread Status:
Not open for further replies.
  1. Hazardoze

    Hazardoze New Member

    Hello everyone, I own a macbook and I was considering on buying the basilisk v2 just because but I saw that you needed synapse 3 for this to work, so, you can't customise it with synapse 2? thanks
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    Yes, Basilisk V2 is using Synapse 3, older 2.0 version is not supporting any new Razer peripherals.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >