Razer Blade Stealth Late 2019 Touchpad / Trackpad issues

Discussion in 'Systems' started by Hexwrench, Dec 14, 2019.

Thread Status:
Not open for further replies.
  1. Hexwrench

    Hexwrench New Member

    I just wanted to see if anyone else was having issues with the touchpad on the Razer Blade Stealth Ice Lake. I bought the Elite Care plan so it should be covered but wanted to see if this is a common issue since these are the laptops that I have chosen to issue to employees of my company. The issue I am seeing is when I rest my right hand where the palm is touching the space to the right of the touchpad and try to two-finger-scroll, scrolling gets all glitchy. Pretty much any pressure to the right of the pad will do it. I tried to make a video that captures the issue here:

    Video of touchpad issue
     
  2. xc68000

    xc68000 New Member

    Are you using the factory windows install or did you re-image? I had the same issue with my blade 15 and after upgrading my ssd and reinstalling Windows, had to re-create the MS Precision Touchpad drivers registry entries. There is an offset value that is required as the trackpad is large and offset to the right where your right palm sits. I'm uploading the ones i've added based on research here and on reddit. I have no idea if these are correct but they seemed to have helped.

    upload_2019-12-16_9-45-54.png
     
  3. 8ruce007

    8ruce007 New Member

    I have noticed sometines it's glitchy but mainly seems to happen when I'm on battery power using battery saver, when I use it plugged in I don't seem to have any issues, I have tried checking for a driver update but there isnt any yet/

    I have tried pressure on mine and can't recreate the problems your experiencing
     
  4. kaivon17

    kaivon17 New Member

    I have the same problem. Just bought the late 2019 stealth today. Absolutely love it until I opened reddit to do some browsing and found out half the time the two finger "scroll" on trackpad is very bad. Half the time it registers it as a left tap or left click, other times it just scrolls through the whole page even at the slightest touch. Once today I even just put gently put two fingers on the trackpad without movement and it just went through a whole long page....

    Also the trackpad has done really random movements when doing this I've tried turning off pinch to zoom, adjusting the trackpad sensitivity - none of it helped.

    I tried to find a solution but since we have a different software (under device manager for mouse we have a "razer stealth" not the synaptic or elan) than other razer blades or older stealths this solution won't fix it as far as i know .

    I'll be going to return it tomorrow unfortunately. I'm doing a factory reset as we speak but even if that fixes it I don't know when down the road it will start acting up again. For this amount of money I shouldn't have to go through this hell on my first day.

    ().
     
    Last edited: Dec 21, 2019
  5. debugy2k

    debugy2k New Member

    I just got the new GTX model today. Dropped in a 2TB SSD and did a new install of Windows 10 using a legit Microsoft Windows 10 usb install drive. The touchpad didn't work during installation at all and I thought it was drivers related. After Windows got installed and updated, the touchpad still didn't work. I added in those registry keys that you showed and still nothing. Anywhere to get the touchpad drivers?
     
  6. xc68000

    xc68000 New Member

    Sorry have no idea. When i reinstalled windows 10 it recognized the precision touchpad and loaded drivers without issue.Those reg settings were just complimentary to the ones windows created.
     
  7. Joikansai

    Joikansai Well-Known Member VANGUARD

    Did you try update all drivers for your model from Blade stealth support page and also intel drivers by using Intel update utility? It sometimes solves hardware issues after ssd upgrade or fresh windows installation.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >