Razer Central stuck in infinite log-in loop.

Discussion in 'Razer Support' started by Charcocoa, Apr 28, 2019.

Thread Status:
Not open for further replies.
  1. Charcocoa

    Charcocoa New Member

    Razer Central has been stuck in an infinite log-in loop for at least a week now. It's not giving any sort of error, it's just stuck on the logging in screen, screenshot below. I've tried solving the issue myself, and here's what I have tried:
    • Patiently waiting, often for hours
    • Closing and re-opening Synapse 3
    • Restarting the whole computer
    • Repairing the Synapse install
    • Uninstalling and reinstalling, several times
    • Uninstalling, with deleting every Razer-related file in Program Files, both in normal and 86x, then reinstalling, at least twice.
    • Resetting the password on RazerID (identical to the previous password)
    • Resetting the password on RazerID (a completely different password)
    • Reinstalling the drivers via Device Manager, using the Update Driver option, and reinstalling due to the drivers causing the installer to open up again.
    I have confirmed that this is entirely local to my machine. On my laptop, which was on the same exact network (except over WiFi rather than LAN), I successfully logged in, even after I updated synapse to be the exact same version I'm in right now.

    As it's a reinstall, it should be using the latest update, which is 7.3.11.110. I'm also on Windows 10.

    Screenshot: [​IMG]
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest

    Hi there! Let me help you out with this. Please PM me the link to this thread as well as the build/version number of Synapse. Let's continue there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >