Razer Deathadder Elite is not turning on or responding to any computer.

Discussion in 'Razer Support' started by bigfishcool21, Oct 24, 2021.

Thread Status:
Not open for further replies.
  1. bigfishcool21

    bigfishcool21 New Member

    So after I've gotten home from shopping, I've noticed that the ice in my water bottle, which was right next to the wire of the Deathadder Elite mouse, had melted, and there was some liquid semi-submerging the wire. I took a moment to wipe off the puddle and to dry the wire of my mouse.

    I plugged it back in to my laptop and it was working just fine. But after 30 minutes, my Razer Deathadder Elite had suddenly shut off and it was no longer working or being recognized by my laptop. I tried connecting the mouse to other computers to see if it was just a problem with my computer's program, but the mouse does not work or turn on to other computers as well, so something is wrong with my mouse hardware. It's completely unresponsive, doesn't connect, LED is completely off, no cake.

    The only thing I've noticed is that I still see the red glare in the bottom of my mouse, in the sensor (turns on to any computer), which really dumbfounds me.

    Can anyone help detect the issue here? I would really much appreciate it.
     
  2. Razer.GuitarScar

    Razer.GuitarScar Active Member

    I'd like to take a closer look at the situation. Please send me the serial number of your device via PM. That way, I can use it to look into firmware-related solutions. Let's go from there. I'll lock this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >