Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

razer elcetra v2 usb wont work

Discussion in 'Audio' started by mrblicher, Jan 11, 2020.

Thread Status:
Not open for further replies.
  1. mrblicher

    mrblicher New Member

    hi i got an Razer Electra V2 USB headset 2 monthts ago, and it worked fine the first two weeks but then it started to stop when i was playing, so i had to plug it out and plug it in again. and then it worked fine. It was like that in a month, but yesterday when i plugged it out and in again, the sound never come back. and then my pc wont recognize my headset and it just wont work. what can i do. Regards: Gustav
     
  2. AscensKS

    AscensKS New Member

  3. mrblicher

    mrblicher New Member

    thanks for your reply. but unfortunately i cant do that because when i plug my headset into the computer it says "windows cant recognize this device". So the firmware updater cant register that there is an headset plugged in.
    best regards Gustav
     
  4. whoDAfunk8

    whoDAfunk8 New Member

    I have the exact same problem, "Windows can't recognize this device" Help?
     
    mrblicher likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >