Razer Mamba elite stops working

Discussion in 'Razer Support' started by Strafy, May 20, 2019.

Thread Status:
Not open for further replies.
  1. Strafy

    Strafy New Member

    Okay so I got my razer mamba elite about 6 months ago I think,via the razer website.About 3 months ago it just randomly stopped.I wuldunt be doing anything and all the rgb lights stopped so I unplugged an plugged back my mouse.The rgb lights were not comming on and razer synapse wuldunt recognize my mouse.I contacted support and they said to ship it to them.So I did just that.They said nothing is wrong and shipped it back and It was working.Now I got the same problem.Is there a way to get a new one eaven if they say it’s working because it’s clearly not.Thanks for help guys (sorry for my English)
     
  2. ARMOR_152

    ARMOR_152 Well-Known Member

    Have you tried reinstalling Synapse? And using different USB ports?
     
  3. Strafy

    Strafy New Member

    I haven’t tried reinstalling synapse but I’m using a different mouse and it works just fine.But mouse doesent eaven show up on my screen so I don’t think it’s synapse
     
  4. Lauriat

    Lauriat Title: Entitled

    Weird. Have you tried plugging it into a different PC?
     
  5. Strafy

    Strafy New Member

    Yes i have.Not working.Im sure my mouse is broken becouse it sometimes works for about 2hours and then stops working agian.
     
  6. Lauriat

    Lauriat Title: Entitled

    I'm afraid this is already a hardware issue. Can you send me a video to document this? Just upload it in Google Drive and send me the link via PM. Make sure to include your unit's serial number as well.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >