Razer Mamba Wireless not turning on after update

Discussion in 'Razer Support' started by 025PRO, Mar 30, 2021.

Thread Status:
Not open for further replies.
  1. 025PRO

    025PRO New Member

    Recently I noticed that the mouse would disconnect/connect while playing a game which was annoying, and I checked for firmware updates. I follow the steps from here https://mysupport.razer.com/app/answers/detail/a_id/1635
    the dongle was updated, and when the mouse update started, I noticed that the lights turned off, and after all the progress of update finished, I didn't get to the page saying the device was updated, but the Update button was also disabled. So, after waiting for an hour it didn't change anything and I disconnected the cable from mouse, tried to turn off and on the mouse, but the lights will not light up. Tried system restart, then connected the cable, but there is no reaction at all. What can I do? I'm curious if the updater killed my mouse (((
     
  2. 025PRO

    025PRO New Member

    UPD.

    This is how it progress

    UPDATE_progress.PNG
    and here is what it shows up after reaching 100%
    update_end.PNG
     
  3. 025PRO

    025PRO New Member

    I found the installer for 1.02.0 version and used it. The dongle didn't get updated, but somehow the mouse update started and finished successfully, and the version was set to 1.02.0 and after it the mouse started working again. The lights came back. Then tried running the updater with version 1.12.00 and the problem started again. Will use the older firmware as a workaround now, but not sure if there will be a problem as dongle got updated to 1.12 and mouse is 1.02


    UPD: and now it seems the installer with older version didn't work anymore(((
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >