Razer Peripheral (Mouse) Stopped working after MacOS Big Sur Update

Discussion in 'Razer Synapse' started by awesomeSpanishCrimson199, Nov 18, 2020.

Thread Status:
Not open for further replies.
  1. ghasemikasra39

    ghasemikasra39 New Member

    I have the same issue with my DeathAdder v2 mouse. I am running a macOS big sur. But my app is a fresh install for the first time. I did not have Razer app on my Catalina. Please fix this issue, I don't want to try Avaddon method.
    Screenshot 2020-11-28 at 23.58.31.png
    Screenshot 2020-11-28 at 23.58.50.png
     
    ShingoKani likes this.
  2. Binky1138

    Binky1138 New Member

    This sounds like the sort of thing a class action lawsuit is meant to remedy.
     
  3. JFachini

    JFachini New Member

    Please fix this shit
     
  4. JFachini

    JFachini New Member

    Please fix this shit! Costumers don’t deserve such thing.
     
  5. JFachini

    JFachini New Member

    Please fix this!
     
  6. JFachini

    JFachini New Member

    None of the methods I found only works. Please fix this.
     
  7. JFachini

    JFachini New Member

    Fix it. Mac users are not less important than Windows users.
     
  8. killa_cam

    killa_cam New Member

    yeah this sucks
     
  9. BURF123

    BURF123 New Member

    Please fix this !
     
  10. byteVanillaroad785

    byteVanillaroad785 New Member

    Please fix this!
     
  11. Moensquad

    Moensquad New Member

    PLEASE FIX THIS!
     
  12. Qetyi

    Qetyi New Member

    I got an update, now it works, but I have to disconnect and reconnect the mouse and the keyboard after every boot. Sometimes it starts to work after reconnecting the USB cables (7 out of 10), sometimes I have to open the Synapse app too (3 out of 10).
     
    LordRunner likes this.
  13. coolOPALAmazon725

    coolOPALAmazon725 New Member

    peep this: https://github.com/1kc/razer-macos
     
  14. TomPasse

    TomPasse New Member

    I fixed it. You can fix it in 5 Minutes. The key is your Terminal. Follow these steps and it will work again.
    First time it didn't work ´cause I wrote Lib(r)ary false in the terminal, haha.
    Here is a YouTube discription and it will work!



    Let us Play again! :) cheers
     
  15. chrisogg

    chrisogg New Member

    If razor is serious about selling products to Mac users, they should fix this in a big hurry....I'll add my name to the list of people who's Razor product stopped working with the MAC update....
     
    ShingoKani and Webas like this.
  16. Webas

    Webas New Member

    @razer PLEASE FIX THIS!
     
  17. rushCerisealley848

    rushCerisealley848 New Member

    I concur with the others. I just updated to Big Sur and have a Razer keyboard from 2019. It's not being recognized by the OS. Razer, please FIX this ASAP.
     
  18. bu11etpr00f

    bu11etpr00f New Member

    Please fix this!!!
     
  19. Nimais

    Nimais New Member

    It says "kextload/Library/Extensions/RazerHid.kext: command not found" when I do this. It did show the Razer TEAMID was added
     
  20. aeroSHELL086

    aeroSHELL086 New Member

    PLEASE FIX THIS
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >