Razer Synapse 2 not opening

Discussion in 'Razer Synapse' started by blackyboy2017, Jul 25, 2019.

Thread Status:
Not open for further replies.
  1. RegarD_

    RegarD_ New Member

    me windows version 1909 wont open
     
  2. LucasFur

    LucasFur New Member

    Im here in 2020 ... till having the same issue with not being able to open synapse ... both 2 and 3. -- maybe we should return the keyboards and buy corsair?
     
    PurpleSim likes this.
  3. nobusinesshere

    nobusinesshere New Member

    Spent all yesterday figuring this out, the razer synapse 2 install on the website does not work, instead you should download razer surround here: https://support.razer.com/software/surround/
    1) Uninstall Razer Synapse 2.0 and any residuals in the ProgramData folder
    2) Install Razer Surround (it comes packaged with Razer Synapse 2.0)
    3) Launch Razer Surround and let it do whatever updates it wants to
    4) Uninstall Razer Surround, but not Razer Synapse 2
    5) You should now have a good install of Razer Synapse 2

    Technical:
    The problem is that there is a file in the standard razer synapse 2 install that seems to be grossly out of date. The RazerConfigNative.dll in the normal install has a created date of 2015 and is not digitally signed by Razer. If you grab the Razer Surround install instead, it correctly uses a RazerConfigNative.dll signed by Razer in November 2019. If you use the normal install and try to check the log files in the ProgramData folder, you'll see that it is failing a "IsSignedByRazer" check on the dll and crashing.

    edit: I read the thread a little more, seems like some people might have other issues here. But what I'm pointing out is specifically a Razer issue and not an issue with a particular version of Windows. The current Razer Synapse 2.0 download will not work on any system as of this moment.
     
    Eremiell likes this.
  4. Eremiell

    Eremiell New Member

    Thank you, this solution worked for me.
     
  5. LucasFur

    LucasFur New Member

    I already returned my wife's whole set up. Shes now a corsair head.
    Some reason it worked on my windows 10, so im still using razer products. but this has me questioning .... how few items of razer are being purchased if there are so few people coming across this issue.
     
  6. SammyVonHauguth

    SammyVonHauguth New Member

    I have the same problem, won't ever buy a product from Razer again, gonna go with other brands. Razer makes bad softwares that don't work.
     
  7. Thank you, it worked but I had to hunt it down with WayBackMachine because they purged all their site of the v2 release and the v3 release does not bundle anything but the surround stuff...

    http://dl.razer.com/drivers/Surround/win/RazerSurroundInstaller_v2.0.29.20.exe

    Cheers
     
  8. cripttt

    cripttt New Member

    Cheers. All you really need is the DLL though. Someone might wanna upload it somewhere. Razer should really just upload that DLL in their repository. It goes to their cloud to obtain the file and gets the old 2015 one.

    If you are running into this issue, the following will be logged:

    Code:
    2020-05-26 09:36:27,877 [SynapseMain::20440] DEBUG Razer.Emily.UI.CommonConfigNativeOps [(null)] - loadDLL from C:\ProgramData\Razer\Synapse\Devices\RazerConfigNative.dll
    2020-05-26 09:36:27,881 [SynapseMain::20440] ERROR Razer.Emily.UI.CommonConfigNativeOps [(null)] - IsSignedByRazer failed.
    2020-05-26 09:36:27,882 [SynapseMain::20440] DEBUG Razer.Emily.UI.CommonConfigNativeOps [(null)] - lodDLL failed, path=C:\ProgramData\Razer\Synapse\Devices\RazerConfigNative.dll, error=183
    2020-05-26 09:36:27,883 [SynapseMain::20440] DEBUG Razer.Emily.UI.CommonConfigLoader [(null)] - StartConfig::Failed to load the common configurator, path=C:\ProgramData\Razer\Synapse\Devices\RazerConfigNative.dll, vers=2.46.0.0
    2020-05-26 09:36:27,886 [SynapseMain::20440] DEBUG Razer.Emily.UI.SynapseApp [(null)] - UpdateChecker:: Started, Expire @ 05-26 09:38:27, 
     
  9. MrSlimeZ

    MrSlimeZ New Member

    same problem
     
  10. goaharis

    goaharis New Member

    May 2020 - still I am having the same problem. it shows in a task manager but not on the screen
     
  11. CKS1991

    CKS1991 New Member

    Hi, they replaced the surround with 7.1 surround which not included synapse. Is your link included the synapse? i tried using your link to download it and install but i cant launch the synapse. After installed, i click on the synapse icon but it only come out the surround setting even i uninstalled the surround it still the same.

    Any advise?
     
  12. B1ueone

    B1ueone New Member

  13. ScreamingSpaceGoat

    ScreamingSpaceGoat New Member

    I ended up stumbling on a fix that worked for me.

    On a fresh install, after you log in, it'll attempt to update. I didn't let it finish by closing Razer's update manager in the Task Manager. I opened Synapse and after a bit a window popped up asking if I wanted to update Synapse. I told it to update and when it was finished Synapse worked just fine.

    This was with Synapse 2.
     
    cripttt likes this.
  14. koukii-koukii

    koukii-koukii New Member

    same here not working
     
  15. technosignsCream609

    technosignsCream609 New Member

    Got mine working by going to C:\Program Files (x86)\Razer (Where you installed razer synapse)
    Deleted every folder apart from the synapse folder.
    Went into the folder and clicked RzSynapse.exe and it booted up straight away.

    (I also clicked RzUnlockAgent.exe but I dont think that did anything)
     
  16. Rouvald

    Rouvald New Member

    I managed to install everything, but now when I turn on the surround sound at synapse 2, interference and robotic noise appear
     
  17. Kukuuruuza

    Kukuuruuza New Member

    Same robotic sound for me too.
    I have a fresh version of latest windows 10 x64 and have not messed around with it.
    On my previous windows the application worked as a charm.
    But now the sound is so bad, it lags and screaks and the sound is unbearable.
     
  18. Kukuuruuza

    Kukuuruuza New Member

    All these years since i bought the Razer surround pro application, I have been using it with generic setup (not with razer headset) with many other headsets. And everything worked great. I liked the widened sound stage, improved positioning audio and all the other options.

    Now when I installed the application on the fresh version of latest windows 10 - the sound is very laggy, robotic - just plain bad - regardless of which headphones/speakers i connect to my PC.

    This is not a speaker/heaphone issue, but rather the application compability with windows 10 current version.
     
  19. Kukuuruuza

    Kukuuruuza New Member

    I've been in touch with Razer support since May.
    Most of the time they just answer with some random pre-defined text that which makes me facepalm every time.
    Today they finally admitted that it is the lates windows update that broke the surround pro application.

    Now i'm being asked to reinstall windows to some earlier version to test if app works on it.... Kinda nonsense but ok.

    By the looks of how "fast" and "interested" the support is -
    I have around 2% belief that this problem might be fixed by 2022 if fixed at all.

    Kinda sad.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >