Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer synapse 3 "Failed to start"

Discussion in 'Razer Support' started by TheZyro, Aug 19, 2020.

  1. TheZyro

    TheZyro New Member

    I had this problem today i returned from my cottage home and this jumped into my face after startin my WINDOWS 7 pc. can anyone help pls? :frown_:
    I allready tried youtube tutorial fixes and also forum fixes and nothing helped me :slightly_sad:

    2013 RAZER FAN // BlackWidow Chroma V2 // TheZyroCZ
     

    Attached Files:

  2. FiszPL

    FiszPL Well-Known Member

    Any logs from Windows Event Viewer? Sometimes it gives a nice details what's wrong, why the app is crashing etc.
     
  3. TheZyro

    TheZyro New Member

    allready have sent it to razer helper
     
  4. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey @FiszPL! Thanks for the offered assistance.

    Hi @TheZyro. I've replied to your PM. I'll wait for your follow-up.
     
    FiszPL likes this.
  5. ola, estou com o mesmo problema e nao sei oque posso fazer
     
  6. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! I've tried translating your comment through Google. If your Razer Synapse is not loading, please perform the steps on this link. Let me know if it helps.
     
    FiszPL likes this.
  7. ja fiz isso mais nao resolveu
     
  8. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Please communicate with me in English so I can assist you better. Should the issue persists, please send me a PM. Let's continue from there.
     
    FiszPL likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >