Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. cpoChiD

    cpoChiD New Member

    so while using the Tartarus V2, the d pad sticks and you keep moving in one direction till u press the same direction again. I know a lot of people have this problem while looking through the forums and the one solution is to delete razer synaps. but unfortunately I use a lot of razer products and that's the best way to match and customize RGB. so its either I deal with that annoying glitch and have cool colors and effects. or i delete synaps and don't deal with that glitch but now half my RGB features are useless. I was hoping to bring this back to the attention of the developers to see if u can make a small patch for synaps so the people who use the Tartarus can enjoy there gaming and RGB lights at the same time. Please and thank you.
     
  2. Nate__tm_

    Nate__tm_ New Member

    I second this..
     
    cpoChiD likes this.
  3. the_novena

    the_novena Member

    I am also encountering this, and am about to open a ticket with them. I too researched the issue first, and found pre-existing reports of this. Based on this, I have put together my own comprehensive report.

    I am a Razer enthusiast. I own their Tartarus Pro keypad (which replaced my previous Razer Orbweaver); Black Widow Elite keyboard; Naga Trinity mouse; and brand new Blackshark V2 headset that I haven't even unboxed yet which are an early Christmas gift. My history with Razer has been nothing short of outstanding (including times I have required formal support), so I have every hope and expectation that they will be helpful with this issue.

    Since I put a fair amount of time and effort into researching the issue and documenting my own issues with the "repeating" D-Pad issue, I am attaching a copy of my report here. This way, the Razer community can find some solidarity and hopefully some further insight on this problem. I will continue to chime in with any updates.

    Aside from my report attached, I would add my own following replies to the original poster's specific points:

    One small difference between my own issue and the original poster's: pressing the same button again on the D-Pad does NOT stop the "repeating", in my case. ... Instead, I must press the corresponding direction (W, A, S, D) on my keyboard. Although this is a small difference, it is significant. Well ... it's significant to me, at least, lol -- because it completely interrupts the fluidity of my game-play having to switch devices in the middle of action (or combat!).

    Exiting Synapse 3 does indeed successfully eliminate the problem entirely. However, on top of sacrificing the aesthetic RGB that we all love so much, it also means I lose all of my custom key binds since the Tartarus Pro does not have on-board memory. If I wanted a gaming keypad where I had zero control over how the keys are mapped, there are several much cheaper options on the market. Razer's Tartarus won my heart precisely because I could customize the key bindings! ... I endured the default key bindings when I exited Synapse for a few days of trouble shooting, but wow -- I found it very awkward, and would not enjoy gaming like that on the regular. Thank goodness my Naga Trinity has onboard memory. If I had to lose those binds too, due to exiting Synapse, I might've ended up hanging myself with my own mouse cord by the end of day two!

    Finally, in case it's helpful, here's what I'm operating with:

    Operating System: Windows 10 Home (10.0.19041)
    Razer Software: Synapse 3 (version 7.3.30.156)
    Game: Elder Scrolls Online

    (Note: since there is no provision for me to upload a pdf file here, I'm uploading my report in three separate jpg's; one for each page of the document. This renders the embedded links inoperable, but I can provide them if anyone needs them. Otherwise, I'm sure they can be easily found through an internet search by title)

    I'm happy to provide any other details/answers/insights if required. Fingers crossed in the meantime, that we can get some answers -- and hopefully some resolution! -- soon.

    Keep safe, stay positive, and game hard!
    =)
     
    SilentSleeper83 and cpoChiD like this.
  4. the_novena

    the_novena Member

  5. the_novena

    the_novena Member

  6. Seegeth

    Seegeth Member

    Tartarus Pro, sticking keys problems, pressing same key helps for me.
    Device bought one week ago.

    I tried:
    Guest Razer Account
    New Razer Account
    Reinstall Synapse 3
    Clean Registry and Drivers (Razer)
    Setting button to Turbo Mode

    Nothing helped.

    Operating System: Windows 10 Pro (20H2)
    Razer Software: Synapse 3 (version 3.5.1215.121019)
    Game: Cyberpunk 2077, World of Tanks
     
  7. KAWAiiSONG

    KAWAiiSONG New Member

    Hi everyone, I have the same problem for a long time. only those keys that have been reassigned stick, it helps to disable Synapse or re-press the stuck button! as I have already noticed from the answers of other users of this forum, sticking in different games, which means the problem is in Synapse! I talked to support for almost 3 months until the mouse broke down and I had to stop talking! here I have a new Razer Naga Pro, and the same problems with sticking buttons.

    Please help with this problem

    Operating System: Windows 10 home (20H2)
    Razer Software: Synapse 3 (version 3.5.1215.121019)
    Game: Black Desert Online
     
  8. the_novena

    the_novena Member

    After the latest most recent troubleshooting steps that Razer support recommended, the issue persists. I have advised them, and await their reply. I don't expect they'll ask me to ship my Tartarus Pro back to them (I really hope they don't!) -- I'm convinced that the issue is completely software related.

    If it is indeed software related, then it's good news/bad news: The good news is -- it's not our devices; we don't have to go through the nuisance of shipping them back! The bad news is that isolating a software issue is likely to be a pretty challenging task for the Razer tech team/developers ... so who knows how long it will be before we see a fix for this??

    It is frustrating that our devices are clearly not functioning as intended; this is sub-optimal performance to be sure. I'm willing to bet that it's frustrating for Razer too. It should go without saying that they're pretty heavily invested in making the end-user's experience as amazing as possible and I expect they're nearly as unhappy as we are when they fall short of that. Their customer support has been nothing short of outstanding when I've needed to rely on it in the past, so based on all of this, I have every expectation and confidence that they will give this issue the attention it deserves. I don't know how quickly or easily the fix will come (it may take some time!), but I have to believe they will direct the resources towards this issue.

    Frankly, I'm relieved that re-pressing the same D-Pad button is sufficient to stop the repeating. At least it's lowered my pain-scale rating from a near-four, to a three. Yeah: it's inconvenient to have to rely upon a work-around, but at least it's a tolerable work around. Thank goodness I'm not a competitive gamer!

    (I wish there was more I could do, from the user-end, to help isolate the issue or identify any triggers. I've submitted Synapse logs to them, and will continue to do this -- along with anything else they might ask -- as needed. I don't like to complain about a problem unless I am willing/able to contribute to the solution)

    I'll try to provide an update when Razer support replies to my most recent case notes, but honestly I don't know if/what else they'll be able to say or do or advise at this point. It seems to me like the ball is squarely in the court of their Synapse software team.
     
  9. Seegeth

    Seegeth Member

    I hope the problem will be fixed, but I am concerned that there is information on the internet about this problem. Posts last up to 8 months.
     
  10. CptCraptacular

    CptCraptacular New Member

    give up and take your £100/$100+ loss because they dgaf they stopped getting back to me because they have seen it is because of thier software and inability to put a 50c internal memory controller in their product
     
  11. the_novena

    the_novena Member

    You're both right -- it definitely appears to be a long-standing issue which doesn't bode well for a quick fix ... and yeah, it definitely would've been nice if they could've put onboard memory in the device.

    Since the issue seems to be with the way the Tartarus communicates with the Synapse 3 software, then it's important to make the distinction that onboard memory wouldn't actually be a fix -- it would simply be a more desirable way to work around not running the Synapse software. But for those of us with Razer keyboards/mouse and other peripherals that rely upon the software: it just isn't practical for us to quit running Synapse entirely.

    Here is some potentially good news for users for users who don't rely upon the Synapse 3 software for other devices and/or RGB lighting, but need a method by which to assign custom keybinds:

    ~> SEE NEXT POST: Forum platform generates error when I try to embed YouTube video here <~

    Note that this is a paid (though very inexpensive) software download. I am not affiliated with it in any way, but I stumbled upon it late last night. Take a couple minutes and read through the comments under the YouTube video; you'll see that it looks like a promising and viable work-around. After considering the price tag of Razer devices, it certainly stings to have to consider paying for a third party download ... however, it also stings to consider our pricey gaming keypads as nothing more functional than a paper weight.

    There may come a point when I will resort to that download myself. I guess I should count my blessings that my mouse (Naga Trinity) has onboard memory for custom keybinds ... but not for macros. It's just the macros, and the ability to fine-tune the settings for my headset (audio and mic settings), and the custom RGB lighting that makes me still reliant on Synapse 3.
     
  12. the_novena

    the_novena Member

  13. Seegeth

    Seegeth Member

    thanks, i use this software for gamepad
    will test it tomorrow
     
    the_novena likes this.
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! I appreciate this thread. Thanks for sharing your feedback and work around as others can benefit from this information. Please check the isolation steps below:

    a. Disable Razer Synapse and see if the issue persists by following the steps on this link: https://support.razer.com/articles/1663836751

    b. Connect the Razer Tartarus V2 to a different USB port or computer.

    c. Gather Razer Synapse 3.0 logs: https://support.razer.com/articles/1764787021
    d. Repair Razer Synapse 3.0:
    1. Right-click the Start button.
    2. Select Apps and Features.
    3. Search for Razer.
    4. Select Synapse.
    5. Choose to uninstall.
    6. "Uninstall" again.
    7. Wait for the Razer menu to open, then select "Repair".
    8. Wait for the repairing process to finish and restart once it prompts you.
    9. Central services will request you to log in, then launch Razer Synapse.

    e. Clean reinstall Razer Synapse 3.0: https://support.razer.com/articles/1699349771
     
    the_novena likes this.
  15. Seegeth

    Seegeth Member

    Today, i will try to disable Synapse and test it.
     
    the_novena likes this.
  16. the_novena

    the_novena Member

    Okay folks -- it looks like we got their attention! :cool_: Now is the time for as many of us as possible to speak up (nicely and respectfully), do the recommended troubleshooting, and have your voice counted. If Razer support sees the volume of users this issue is affecting, and that we are prepared to go through the steps to help isolate the issue if possible, ... well then, the better the chances we might get closer to a fix, sooner! Or at the very least, we'll be able to rest assured that we've done everything possible to be a part of the solution! :wink_:

    Thank you SpeedCr0ss; I appreciate your attention and contribution to the discussion here. I have reported on my own individual experience (with this issue, and troubleshooting steps) throughout this whole thread, and I would also like to refer you to my open ticket: Razer Incident #201215-001862 -- "RazerTartarusPro - Directional pad still registering input despite releasing the button". To address the steps you've specifically outlined above, I will summarize as follows:

    a. Disable Razer Synapse and see if the issue persists.
    :white_check_mark: December 7 - 11: Disabled, exited, closed Razer Synapse for a few days. Played a three or four gaming sessions of approximately an hour and a half each, and one longer gaming session of approximately three and a half hours. The device worked beautifully; all functions were perfect; no issues at all.

    b. Connect the Tartarus to a different USB port or computer.
    :white_check_mark: December 17: (This step was performed with Synapse running again). Moved the Tartarus Pro from the USB port on the front of my tower, to one of the rear ports of my tower. The issue persisted.
    :white_check_mark: December 17: Plugged the Tartarus Pro into a whole different computer (which does not have any Razer software installed). Played for an hour and a half, and then again later for three hours. The device worked beautifully; all functions were perfect; no issues at all.

    c. Gather Razer Synapse 3.0 logs
    :white_check_mark: December 21: Gathered Razer Synapse 3.0 logs (see my Razer Incident #201215-001862 for link to zip file)
    :white_check_mark: December 21: Applied brand new update to Razer Synapse (3.5.1215.121019); the issue persisted.
    :white_check_mark: December 27: Gathered Razer Synapse 3.0 logs Pre-Clean Install (see Razer Incident for link to zip file)
    :white_check_mark: December 27: Gathered Razer Synapse 3.0 logs Post-Clean Install (see Razer Incident for link to zip file)

    d. Repair Razer Synapse 3.0
    :white_check_mark: December 1 - 2: Ran a 'repair' of Razer Synapse 3.0 ... the issue persisted.
    :white_check_mark: December 3 - 4: Did a standard uninstall of all Razer software (including Synapse 2.0, Synapse 3.0, and another piece of Razer software I can't recall the name of), and did a standard reinstall of Synapse 3.0 (including Macro module, and Chroma Studio module) ... the issue persisted.

    e. Clean reinstall Razer Synapse 3.0
    :white_check_mark: December 27: Followed each and every step in Razer's recommended procedure for a clean reinstall of Synapse 3.0 including running the Windows DISM tool and Windows System File Checker tool; gathered System File Checker details (see my Razer Incident for link to that .txt file) as well as gathering pre- and post- Synapse log files (see my Razer Incident for link to those .zip files). Note: Ever since that date I only reinstalled the core Synapse 3.0 software -- nothing else -- even still, right up to this moment, I have not even installed the Macro module, nor the Chroma Studio module. ... the issue still persists.


    Furthermore, just to demonstrate the (growing) number of users who are encountering this issue, here is a fairly comprehensive list of all the online forum discussions I have found:

    Four or five different users describe the same issue on this reddit thread -- Nov.2017 - Jan.2018

    Posts #4, #12, and #14 on this Razer Insider thread describe this issue -- Apr.2018 - Aug.2018

    Seven users discuss D-Pad issues (switches/software?) on this Razer Insider thread -- Jun.2018 - Sep.2018

    Four different users describe the same issue on this reddit thread -- Jul.2018 - Jan.2019

    Two users describe the same issue on this Razer Insider thread -- Nov.2018 - Jan.2019

    A user described the same issue on this reddit thread -- Mar. 2019

    Three users discuss what sounds like could be the same issue on this Razer Insider thread -- Oct.2020

    Nine users here on this Razer Insider thread -- Nov.2020

    Two users discuss the same issue on this Razer Insider thread -- Nov.2020

    Two users here on this Razer Insider thread -- Dec.2020

    One user here on this Razer Insider thread -- Dec.2020

    One or two users here on this Razer Insider thread -- Dec.2020

    This list represents approximately 40 users across twelve different posts, over the past three years. This is in addition to myself and the five other users who have contributed on this particular thread, here. Clearly there is some solid history behind this issue, and a whole lot of Razer users who are really wanting to love the Tartarus as much as we expected to.
     
    olPiG and jhnclvr like this.
  17. Seegeth

    Seegeth Member

    Until this moment I tried

    b. Connect the Tartarus to a different USB port or computer.
    d. Repair Razer Synapse 3.0
    e. Clean reinstall Razer Synapse 3.0


    Nothing helped
     
    the_novena likes this.
  18. KAWAiiSONG

    KAWAiiSONG New Member

    it didn't help. something is wrong with Synapse 3.0
     
    the_novena likes this.
  19. Seegeth

    Seegeth Member

    a. Disable Razer Synapse and see if the issue persists
    3 hours of World of Tanks without Synapse 3, no problem. Tatarus works fine.
     
    the_novena likes this.
  20. KAWAiiSONG

    KAWAiiSONG New Member

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >